Keyboard problem

Now I’m getting worried as it’s just happened for the third time in a couple of weeks!

Most of the keys on the keyboard just stop responding. The backspace and delete keys work, the caps lock lights up but most of the other keys do not respond. A reboot fixes it. I haven’t opened the case to check anything but it seems to me that if it was a keyboard cable issue, they would all stop working and a reboot wouldn’t immediately get it working again. The trackpad works but not the mouse clicks. I’m on Windows 11, by the way, having installed the latest beta bios and drivers.

I haven’t noticed any similar issue raised so does anyone have any ideas? I haven’t contacted support yet as I thought there are many experienced users in the forum who might be able to help.

EDIT: Also, in case it’s relevant, mine is a Batch 1 DIY.

Eliminate variables:

  • Try typing/backspacing in BIOS
  • Try Windows 10
  • Try Linux over USB
  • Try external keyboard/mouse
  • Reseat input cover connector/clean the socket (I’ve experienced sporadic keys from debris in socket)
1 Like

This sounds most definitely software.

1 Like

Thanks to you both. I think @Josh_Cook must be right. I think it may have something to do with Chrome. It just happened once more. I then connected my bluetooth keyboard. When I typed in Chrome’s address bar, nothing happened with the main keyboard or the bluetooth keyboard. However, if I typed something into the search bar on the Amazon page, both worked. If I typed in Notepad, neither worked. If I closed Chrome, both worked in Notepad. When I reopened Chrome, both worked normally again.

All very peculiar! First thing I’ll try is to uninstall and reinstall Chrome. The difficulty is that, so far, it is an intermittent fault.

Don’t you just love computers!

1 Like

If your keyboard isn’t working in Chrome, you may be able to resolve the issue by just resetting it to default. Your Chrome profile can become corrupted at times after an update, or an extension can interfere with it.

1 Like

Thanks, @_EJ_bak, I shall try that first.

Similar issues can be triggered by a faulty input method in Linux. For example, applications connected to an ibus will appear broken if the latter had crashed.