Laptop will not power down, And IO has stopped working

I’m running a 12th gen i5 framework with windows 11, and after a recent update it will not power all the way down unless I hold the power button. Along with this, none of the ports are working for anything but the charger. I’ve gone as far as resetting windows, but the problems have persisted.
Anyone have any ideas?

Have you reinstalled the windows 11 driver pack from FW?

Can you post a pic of device manager?

The USB C port works to charge the laptop but you cannot get a handshake when connecting other devices?

1 Like

Yes, the first thing I tried was reinstalling the driver pack from framework, and attempted again after resetting windows, with the same result.

I’ll try to attach a picture of device manager,

And correct. The ports will charge my laptop, but will not recognize or seemingly power anything. I’ve tried hard drives, mice, keyboards, docks, (and an eGPU) but none of them have worked yet.

Ended up using Google Drive to back up the couple of files I didn’t already have on other drives before I did a reset on Windows.

Update: I’ve tried to reset the mainboard as well to no avail.