[Linux] 1TB expansion card disconnects randomly

New here. Batch6 with Intel i7-1165G7. My 1tb expansion card somewhat randomly disconnects and reconnects, I think while doing sustained writes. Tested on linux.

Haven’t diagnosed it properly yet. So I’ll provide some probably useless info for now.

While properly locked in place, the filesystems on the device will suddenly become readonly. Just before this occurs, dmesg shows a usb disconnect event, the fs failing to write a few times and becoming readonly, the usb connect event, and the reconnected block device getting assigned a new letter (sda->sdb->sdc) since the old one is still sort of in use.

So far has only happened while actively writing to the card such as when running emerge -NavDu @world or btrfs receive, and has only happened while in the framework laptop itself (have tried the bottom left and right bay). I have not yet had issues when plugged into my desktop, but it has not spent much time in there yet. It usualy takes several minutes of active writes before it disconnects, taking 15min+, but have had it disconnect once shortly after boot for unknown reasons.

Tested using it from a fresh kali linux install on a seperate flash drive, from gentoo installed on the 1TB ssd itself, and from a fresh arch linux install on my nvme.

My btrfs receive was over ssh and with the network speed around ~160Mbps. The card dis/re-connected at 13Gb within 20min.

Anyone else with similar issues? Any recs for commands I should run for monitoring and testing? Assuming/hoping its a bad flash card for now, but it did happily let my desktop write 200Gb to it (in a much shorter <5 min timespan), and let me compile/install gentoo to it from the desktop over the course of an hour. Its not hot to the touch, but if its a thermal issue what should I do to check (I don’t think lm-sensors shows anything for the card by default)?

relevant dmesg: Framework 1TB expanson card random disconnect - Pastebin.com

@Shy_Guy see if this

https://knowledgebase.frame.work/en_us/one-port-on-my-laptop-does-not-function-correctly-r1mqMnTet

or this

helps.

Good luck!

1 Like

@lbkNhubert Thanks, I tested both sides after reading the first one, but still havn’t tested either of the top two. The second one I rulled out since it was never hot to the touch and my write speeds inside the laptop have been limited by my wifi (no faster than 160Mbps, nowhere near 1000MBps) since all write operations were from downloading files.
I did attempt to measure the temperature via lm-sensors, but its not detecting anything specific for the card. Granted, I did not actually run sensor-detect on the thunderbolt ports (can anyone confirm its safe to probe). But seeing how low my write speeds are I doubt its overheating (plus it has worked fine at full speed in dessktop)

Guess I should test the top ports too. On one hand I don’t want to needlessly wear down the card, on the other its likely either the card or mobo is faulty and I need to stop being a puss and determine which. I’ll script something up soon

I’m having the same issue on Windows with the 256GB card. Were you able to find a solution yet?

The problem I am having is not likely one with a solution other than a replacement. Its just a matter of finding the time to positively identify what needs to be replaced.
Or, in my case, waiting for the other expansion card to ship in so I can hopefully rule out the mobo.

If it the new card has the same issue, I will need to check if thumb drives/phone/etc also disconnect randomly/briefly to better understand the scope of the issue. Fact is, so far the only thing I have plugged in is this expansion card so its possible the usb ports just reset or something every few minutes for some unknown reason. I think I saw a post with such an issue a few days ago, but failed to save it.

I don’t actually have anything else to plug in atm other than a display for testing. I haven’t seen it flicker during use so I don’t think its a general error with the mobo.

I usually have a USB headset or a dock plugged in and i haven’t noticed any issues with those, so it could very likely be the expansion card in my case . Please update and let us know.

Having a similar issue with the 250GB expansion card which has Linux Mint installed. It has no warning and will typically happen after a command completes successfully. I’ll be unable to open or run any programs, drives will display i/o errors, and all icons disappear as they are removed from memory. The only way out is a forced shutdown. Typically I have no other devices connected aside from my internal NVME when this happens.

FYI: I just noticed the expansion card got disconnected when I rebooted & plugged in a docking station. Can anyone try to reproduce?

Yep I just reproduced it again and it disconnected right after I plugged in a docking station.
FYI: This is the docking station Im using:

Noticed the same thing with NixOS. I haven’t tried other ports yet.