Linux Bluetooth Issue ... Solved!

So, many are complaining about Bluetooth not working in Linux. This can be a complicated issue, but there is one thing you should definitely do and that might be exactly the solution you’re looking for. (That solved my Bluetooth issue)

Try running the following commands to stop and disable a systemd service called “bluetooth-mesh.service”

systemctl stop bluetooth-mesh.service
systemctl disable bluetooth-mesh.service

And if your problem is the same as mine, congrats, you can now use Bluetooth!


Whoa thank you. Just unboxed my framework yesterday and screwed my “old” SSD with Manjaro-Linux in and had no luck with bluetooth. I suspected some problems with Firmware and Kernel and messed a lot around but to no success. Now it is working. Very good Service, should be pinned :wink:

For completeness: You can also run

sudo systemctl disable --now bluetooth-mesh.service

, which is a shorthand for disable and stop.