This laptop is extremely frustrating

I got my framework in November and it has been extremely unreliable. It randomly powers off at critical moments (usually during conference calls and large compilation jobs), I can’t get it to boot off USB anymore (I’ve gotten it to detect a USB boot disk twice ever when I first installed an OS), the battery life is atrocious, and as of last week it sounds like the speakers are blown out.

Right now I’m trying to run memtest86 to see if my memory (which I purchased with the laptop) is faulty but I can’t get it to boot off the usb drive. I’ve reflashed it a million times, it shows up in the bios, but then it isn’t a boot option in the boot select menu.

If I had known how many issues I was going to have with this laptop I never would have bought it.

Have you disabled secure boot in the BIOS? I don’t think memtest works with it enabled?

I always have secure boot disabled. I can’t boot off a USB drive let alone try to run memtest.

hmm… Just to rule other things out.
Which OS are you running?
How did you flash the USB, (rufus, etcher, etc…) I’ve had issues in the past flashing certain USB drives with different programs getting them to properly load boot partitions.
This person mentions fn lock might be enabled? or waiting 30 seconds after powerup.

I’m using nixos and I use dd to flash the drive. I can load the boot drive selector menu but the usb disk doesn’t show up in it.

Mine’s no longer recognizing USB drives either. Including the one I originally installed Manjaro from. Will try putting Rufus on my USB tomorrow to see if that helps.

What is your bios version?

I’m catious to weigh in on this as I’m not a Linux expert. But I think on most of the issues you listed I’ve seen a thread on this forum related to some Linux distro.

Have you tried one of the OSs officially supported by framework to see if these problems persist?

Indeed, the key things here to pay attention to are BIOS Firmware version (3.07 is current version) and then to isolate whether the hardware is having problems or if your Linux distro has issues. As of right now only Fedora and Ubuntu are officially supported.

I own 2 Framework Laptops and have never experienced any of the issues you are highlighting here. I have run Linux and Windows on each of them.

While you might have a hardware issue going on here, to me the most likely culprit is going to be software based. If we can rule that out, I would recommend you create a support ticket with Framework.


I’m on bios version 3.06. I may try to upgrade today but given the inconsistencies I have experienced with booting of USB drives, I’m nervous to do that.

I’m using Nixos and the issues do not seem to me to be software issues. I don’t get any errors and I haven’t found any logging when it powers off. The machine is just instantly powerd off like it had the power supply cut off.

If in fact you can only run Fedora and Ubuntu on this laptop then framework needs to seriously change their marketing. From the webpage:

You can choose to bring your own memory, storage, WiFi, and operating system, or pick from the many options we offer in the Framework Marketplace.

(emphasis mine)

You can bring your own OS though? They just can’t guarantee every OS to run smooth out of the box, which is understandable imo. They have official guides for Fedora, Ubuntu and Manjaro and if you choose to run something else, chances are someone in this community has already done a thread on that and can help you with any trouble you may encounter.


Look, if you are saying the laptop works fine with 2 distros but not any another then you are either saying there is a problem with the laptop or the distros. Given how many more people are involved in QAing a linux distribution then a small startup’s new hardware, I would be very surprised if it wasn’t an issue with the laptop.

And I’m sorry but I don’t have to go find a thread for whatever linux distro on a community forum to get my Thinkpad or my Intel NUC to run reliably.

Despite looking really nice and having a really awesome concept the framework laptop does not appear ready for actual production use. I didn’t pay $2600 to be an alpha tester.

The BIOS version 3.06 is unlucky version causing below issue. Framework sent an email to ask to upgrade the BIOS version to version 3.07 to all the people using BIOS 3.06 in the past.


I’ll try updating the bios but that is not an issue I am experiencing. I use acpi verify the charge state of the battery.

I wouldn’t say there is necessarily a problem with one of the both, just that they are not compatible out of the box right now. Which is true for every laptop with similar hardware to the Framework where neither a large community (Thinkpads) nor company developers (System76) make that compatibility happen. Things will get better over time, but you can’t expect a small startup to make that happen right out of the gates for every possible distro, especially because some things are out of their hands (wifi drivers for the AX210 e.g.)

I’m running NixOS and am seeing none of the issues that you are listing. I think you are having hardware issues. Mine is Batch 6, I got it last week.


As someone who is running Debian sid on my Batch 5 Framework, I’ve run into exactly zero of these issues. It really sounds like a hardware issue on your end, not a software issue.



What is your bios version?

I’m on 3.06. Was trying to boot from USB so I could upgrade to 3.07. I made the USB image using Linux, but will try Win/Rufus when I have some time. Otherwise, I’ll have to wait until Framework has fwupd working (sounds like it’s not too far off).

First, just a quick suggestion: have you tried to isolate the problem?
A few things that I would try are:

  • Try to boot from a different USB interface: if you are using an USB-A memory stick for the boot OS, try to move the expansion card to a different bay (when the laptop is turned off) and see if things change;
  • Try to reset the BIOS to its default values
  • Try to boot a Windows installation image (I don’t mean to install Windows, just boot the installer)
  • Remove the expansion cards and try to attach an USB-C to USB-A adapter directly on the motherboard’s USB-C port

If any (or all) of the above steps fail, even after updating the BIOS (provided that you succeed in updating it) then you certailny have an hardware issue and you have all the rights in the world to report it to the customer support, pointing out all the tedious steps that you went on to troubleshoot the issue (including the most tedious one: reading my reply!).


@Solomon_Bothwell - that has to be extremely frustrating. The community here is fantastic - make use of it, and hopefully you will get help to determine if you’re experiencing a hardware issue that will need a support request, or if it’s something else. What are the specs of the machine - CPU, ram, and SSD? I have a couple of machines and have not (knock on wood) run into the issues that you’re having. I do recall reading in some threads that people were potentially having the shutdown issues with the WD 850 SSD. That’s what I bought with mine, but I swapped it out for an SK Hynix to try to eke out more battery life. I still have it and can pop it into one of the machines and run some tests to try to reproduce your issues, if you happen to have that drive, and can give some guidance around what you recall doing when it shuts off. I have not run into the issue not being able to boot from a USB drive, I have ventoy set up on a flash drive to fiddle with different OSes and I am able to boot from it without issue. Do you see anything notable in the logs regarding USB when you plug in the drive? Also, is the flash drive configured for EFI vs MBR (my terminology may not be completely correct, but hopefully it’s enough).