[Linux?] DisplayPort Expansion Card Not Outputting

I’m running Fedora 39 on a Framework 16 with the dGPU.

I recently received my Framework in the mail and am absolutely chaffed with everything except for this one minor issue. I am not able to connect my external display using my DisplayPort expansion card that I ordered with the laptop.

I have tried multiple cables, all to no avail; they wake the monitor giving “No Signal” and then nothing after.

The device IS present in lsusb. I have also checked dmesg for any errors relating to the device and there do not seem to be any. It connects and registers normally on startup.

A few other solutions I have tried includes

  • Restarting with the cable plugged in already

  • Plugging in the expansion card with the cable already in

  • Plugging in the expansion card after startup

All of these solutions have been fruitless so far.

Any advice or help would be greatly appreciated, thanks!

I’m in a similar situation.

Port 1 and 2 work, displaying output fine (HDMI and DP). Port 4 and the one on the GPU expansion on the back don’t display output. On Fedora. I’m tempted to try it on windows cause I’m thinking it might be a driver issue.

Changing HDMI/DP expansion to port 1 and 2, the 2nd screen immediately show up in Linux displays settings screen