External Monitor Not Recognized (DP Port)

I tried connecting my external monitor (LG 27GL850) via DisplayPort and the monitor is not being recognized, there is also no sound or any other sign that the DP Port is working.

When plugged in, the external monitor briefly shows “No Signal” and goes to sleep.

My setup: Fedora 37 with the 12th gen i5-1240P, 64gb, 1 TB SSD.

I tried troubleshooting, googling, installed RPM fusion, updated everything that I can but the problem persists.

Ive read that several people in the community have problems with the DP Port but it seems that nobody has solutions which work for me.

Any suggestions what might be the problem or should I request a refund for the DP expansion card?

I believe there was an update for the Displayport cards. I would look into that first. After that, I know you mentioned doing troubleshooting but not what was done so I offer this just incase: double check that the monitor is on the correct input and try the displayport card in different slots. I’ve also seen scenarios where the second display isn’t automatically recognized in Linux and it has to be manually enabled, worth checking too. Your DP cable could also be bad, do you have a way to test it?

Thank you for your reply. I couldn’t find any information on how to update the firmware on Fedora/Linux, only how to do it on Windows. The drivers section on the Framework website says that drivers are included in the kernel for Linux, so I guess when updating the kernel the firmware will be updated too?

The other suggestions I tried and unfortunately it didn’t help.

I tried also $ xrandr -q and it isn’t even showing a display port.

The DP cable is working, thats also not the problem. Tried also different DP card slots, no success.

With the card inserted, what is the output of lsusb? If the card is working, it will show Framework DisplayPort Expansion Card in the list of USB devices.

Here is a screenshot of $ lsusb I dont see “DisplayPort Expansion Card” anywhere. Only Linux Foundation root hub. Does this mean anything?

I was having a similar problem, what output do you get by running



As long as this was the complete output, then it appears it’s not being seen correctly.

Framework DisplayPort Expansion Card

Should really be part of that list. If it produces the same results in different slots with lsusb, then you may have an issue with the expansion card.

1 Like

Yes, it looks like its faulty. I tried every slot and nothing new is displayed with lsusb the same output like posted above, nowhere Framework DisplayPort Expansion Card to be seen. My other expansion cards are working (USB-C and USB).

Please reach out to to support. Let them know you’ve confirmed that it’s a bad expansion card.

Also link to this thread so they have context to what we have done.

1 Like

Can confirm that moving the DisplayPort Expansion Card from the left front to the right front of my 13" (AMD 7040) fixed the issue with it not connecting.