DisplayPort Expansion Card not working

I have a the ROG SWIFT PG278Q monitor, which notably only has a DisplayPort connector, no HDMI. I tried connecting it via a DisplayPort-DisplayPort cable to the DisplayPort expansion card, but the monitor was not recognized (xrandr didn’t show any of the DP-* as connected).

After some troubleshooting I concluded that the DisplayPort expansion card must be the problem, since both the laptop and the monitor worked independently, but the connection between them isn’t. So to fix this, I ordered a DisplayPort-USB-C cable to connect the monitor directly to the laptop (with a USB-C expansion card), and to my luck, that indeed worked like a charm!

Note that in order for the 2560x1440 resolution to work for this particular monitor, I had to follow the instructions in this blogpost:

``` xrandr --newmode "2560x1440" 241.5 2560 2608 2640 2720 1440 1443 1448 1481 -hsync +vsync xrandr --addmode DP1 2560x1440 xrandr --output DP1 --mode 2560x1440 ```

So while I now know that the problem was with the DisplayPort expansion card, I’m not sure if it’s just my expansion card that’s faulty, or if it’s a generic problem with them. I couldn’t find any others with the same problem, so I’m guessing it’s probably the former.

This is just a PSA for others maybe running into the same issue.

1 Like

Same issue here. You’re not alone, others have reported same issue and I have tried the new beta firmware for DP and same issue still exists. For me if I leave the adapter and DP cable connected for a while it sometimes randomly starts working…

Yup, same here. I’ve been chasing the issue of random crashes. After lots of troubleshooting, the laptop ran fine with no expansion cards plugged in. I checked them one by one, and DP card was dead. I still don’t know if it was the cause of the crashes, but the card is definitely dead.

Do they work, generally? Or are they all toast? I’m asking because if they are all toast, I’d rather just get a USB-c card and use a dongle instead (it already proved to work).

Mine works, but the plug is so tight I always rip the card out. I now use the HDMI card.

I’ve had 2, and had the same issues with both. They work sometimes, but mostly seem to just cause issues. Never had any crash issues with them though.

@rstat1 I have had 2 DP cards, and they would work randomly. Is there a problem with the DP cards only? Because the HMDI card I have is working just fine. Do you think the hooks on the DP cable could be causing a problem?

1 Like

@Danny_Von_TechTips Certainly seems like there’s some problem with only the DP cards, as all my other ones (USB-A and C and HDMI) seem to work just fine. The only issues I’ve had with HDMI are just from a flaky OS and not the fault of the card.

I do not think the hooks on the cable are the problem though.

I had similar issue. Solution was to use an “active” display port cable. Check to see if your cable is active. Makes a difference.

@rstat1 Then what do you think the issue with the DP cards is?

Still trying to figure that out. I have no idea.

I have 2 Framework laptops, one personal (11th Gen running Ubuntu) and one for work (12th Gen running Fedora). The work device’s DisplayPort card stopped working recently. I swapped in the card from my personal device and that card works fine, but the failed card does not work on the other laptop. This indicates the issue is not software-related.

For anyone with more expertise, can you open up the card and examine if there is anything wrong with the PCB? Maybe the solder joints are broken or something? @rstat1 @Ragheed_Al-midani

@Danny_Von_TechTips
I’m a Developer, not an Electrical Engineer! :sweat_smile:
In all seriousness, I will take a look to see if there are obvious signs of physical damage.

Got somewhat similar issue with my DP-Card now. It started a few weeks ago, that the card is not recognized directly after startup. But there’s a certain chance, that the card is suddenly recognized after a few minutes. As soon as it starts working, it is perfectly fine for the rest of the session. Using Win10 here.

Edit: Just noticed that my card is in fact working at another expansion slot…

I have a similar issue. Do your cards, when you connect them, also result in the screen “reacting” to the cable being plugged in?

For me, the monitor says there is no dp-signal when I plug it in, and then I can also not see it as an output in my window manager. Putting it in another expansion slot did not work unfortunately.

My issue was resolved by framework support by sending me a new adapter and that is working fine. Maybe a dodgy batch?

I’m already on my 2nd, where it worked for a bit then started having the same issue again.

1 Like

Mine stopped working recently as well. Received my laptop on Friday, used the DP adapter for a few days, but now it isn’t even recognized by Linux when it’s plugged in.

Mine started playing up last night too. Something has to be killing these adapters???

1 Like

I agree there must be something. In the last three weeks, mine was sometimes not recognized by the os (windows or linux) at all. And now for about one week is almost back to normal. Recognition after bootup is sometimes a little delayed, but at least it is working.