Linux Mint 21 still Wifi instability

Hello together,

I received my DIY-Framework end of September and installed Linux Mint 21 Xfce.

Everything is working fine, except for Wifi (Intel AX210, not Pro). It works in general but randomly any transfer is broken, while the Wifi-Symbol still shows connected. A reconnection will solve the issue sometimes for just a few minutes, sometimes for hours.

I know there are lot threats here some are partly old, but I tried some proposals without any improvement:
*kernel changes from 5.15.0-48 to, 5.17.15-051715, 5.19.0-051900, 5.19.13-051913
I think with 5.17 and up the stability is little better compared to 5.15.
*added “wifi.powersave = 2” to /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Does anyone observe same issues on Mint 21 and/or have a solution already?

Any idea is welcome.

Thanks and regards,

1 Like

Hi Michael,

Did you ever find a solution to this problem? I’m having a similar issue with Mint on my gen12 Framework. I can connect to wifi when I first boot the laptop, but eventually the connection stalls. According to speedtest, I’ll still have a connection at something like 0.2mbps. My phone (same wifi network, sitting in the same seat) will get a good speedtest at 25mbps/sec. I reboot the laptop (haven’t tried reconnecting wifi) and it will work again for a while. Sometimes maybe 30-40 minutes, sometimes maybe 10.

I’m on 5.15 kernel, have not intentionally changed that (it might have upgraded from 5.14 since I’ve had the laptop.
I’ve turned wifi powersave off, disabled IPv6, updated all outstanding updates.

If anyone has additional ideas, like Michael I’d love to hear them!