[RESPONDED] Linux: Troubleshooting connection problems with Intel Wi-Fi 6E AX210 No vPro

  • Linux Mint 21.1 x86_64
  • 11th Gen Framework
          .-MMMMMMMMMMMMMMM-.              ---------------------- 
      .-MMMM`..-:::::::-..`MMMM-.          OS: Linux Mint 21.1 x86_64 
    .:MMMM.:MMMMMMMMMMMMMMM:.MMMM:.        Host: Laptop AA 
   -MMM-M---MMMMMMMMMMMMMMMMMMM.MMM-       Kernel: 6.2.12-x64v4-xanmod1 
 `:MMM:MM`  :MMMM:....::-...-MMMM:MMM:`    Uptime: 1 hour, 37 mins 
 :MMM:MMM`  :MM:`  ``    ``  `:MMM:MMM:    Packages: 4110 (dpkg), 23 (flatpak), 
.MMM.MMMM`  :MM.  -MM.  .MM-  `MMMM.MMM.   Shell: bash 5.1.16 
:MMM:MMMM`  :MM.  -MM-  .MM:  `MMMM-MMM:   Resolution: 2580x1720 
:MMM:MMMM`  :MM.  -MM-  .MM:  `MMMM:MMM:   DE: Cinnamon 
:MMM:MMMM`  :MM.  -MM-  .MM:  `MMMM-MMM:   WM: Mutter (Muffin) 
.MMM.MMMM`  :MM:--:MM:--:MM:  `MMMM.MMM.   WM Theme: Mint-Y-Dark-Aqua (Mint-Y) 
 :MMM:MMM-  `-MMMMMMMMMMMM-`  -MMM-MMM:    Theme: Mint-Y-Aqua [GTK2/3] 
  :MMM:MMM:`                `:MMM:MMM:     Icons: Mint-Y-Aqua [GTK2/3] 
   .MMM.MMMM:--------------:MMMM.MMM.      Terminal: gnome-terminal 
     '-MMMM.-MMMMMMMMMMMMMMM-.MMMM-'       CPU: 11th Gen Intel i5-1135G7 (8) @  
       '.-MMMM``--:::::--``MMMM-.'         GPU: Intel TigerLake-LP GT2 [Iris Xe 
            '-MMMMMMMMMMMMM-'              Memory: 8144MiB / 47965MiB 

Maybe this question is a little basic but I don’t know the answer.

Basically, I just want to know how to troubleshoot issues with my wifi connection.

Here’s where I am, I’m running Linux Mint 21.1 (Cinnamon) on a Framework laptop with 11th Gen Intel processor. Back when I started with this laptop, Wifi didn’t even work because it wasn’t supported in the kernel or the support was buggy. However, I found help in a thread about this where it suggested to use a newer kernel. In fact, someone there specifically suggested Xanmod as the means to get newer kernels than what’s on the distribution repositories upstream. I tried that, it worked.

I thought that the card was working almost flawlessly but, a year later, I have found that the connections are extremely unstable on certain Wifi access points that seem to be used in installations from Centurylink (namely, I have noticed the problem connecting to the C4000XG & C4000BG models of WiFi routers). By unstable I mean that connection to the access point is achieved but pings to the outside fail. This may happen immediately or x amount of time after connecting. Also, it could randomly resume a (temporarily) good connection. I’m not ruling out a regression with newer kernel versions because the I never noticed this issue initially and I was using one of these devices back then.

So I would like to know what I need to do to understand what is happening when trying to connect to these devices. I don’t really want to regress & test older kernels. The kernel I was on seems to be 5.19.0-40. However, I just tried Xanmod again to see if a newer kernel (6.2.12-x64v3-xanmod1) would make a difference and the problem remains.

How do I approach this?

Tools I would use:

  • wavemon to confirm connection established, link rates, if the link is getting dropped faster than you think, etc

  • ip a to confirm an IP address gets assigned via DHCP to the adapter

  • sudo dhclient -V interface where interface is the name of your wireless interface, such as wlan0

  • ip route to make sure there is not old route cruft that did not get cleared by the DHCP process above

  • journalctl -r to look for driver errors, or other clues about where connection or packet passing is failing.

In addition to the suggestions above, I’d recommend trying an Ubuntu Live USB - we recommend Ubuntu 22.04 as one of our officially supported distros.

If you’re still seeing issues from the Live USB of Ubuntu (not Mint), it’s worth visiting this page, scroll to the “If you’re dealing with lag or speed issues, provide the output of this to Framework support” section and paste the provided code into a terminal, then reply with what you’re seeing based on the output of the code.

1 Like

I am not at the place with the router that would not connect me to the internet but when I tried the Live Ubuntu it did not have any trouble.

At that time I looked at connecting to a different access point (tethering to phone which was basically bridging to the wifi point) from Mint & it worked fine. I created logs connecting to the one access point and then the other.

The issue where it is failing might be related to entries in the log that read:
iwlwifi 0000:aa:00.0: Unhandled alg: 0x707.

While we recommend Ubuntu or Fedora for official OS support, we do have a recently upgrade Linux Mint guide - I’d start here:

And this is going to bring you to:

Please try matching the recommendations made there.


I’m at my friend’s again (one of 2 places where I’ve seen the problem) and I was pretty hopeful that this would do something to help (since it changes the kernel and tinkers with that one wifi setting) but it has not helped.

I think I might end up buying the antenna module. I have noticed that one of the cables is pinched (I must not have routed the cable property at some point). I’m not sure why I would have consistently bad connections with these specific routers & and consistently good connections elsewhere from a bad cable if the pinching was bad enough to affect function; but at least it seems superficially plausible. Unfortunately, the correct part seems to be out of stock at the moment.

This is very likely the issue. This sounds like the best course of action at this stage.

1 Like

The connection now seems to be working. I’m not sure what changed (I’m pretty sure that I rebooted a bunch of times after doing those changes). I think I’ll still end up buying that antenna module when it becomes available, though (even though I have no explanation for why it would work with the Ubuntu Live or now if bad hardware was the problem).

OK. Maybe it’s not so good. Now I am having issues again. Maybe it’s just intermittency that explains the times when it worked.

Also, though unrelated to the original post, I will note that I needed these recommendations. As it turns out, my built in microphone was not working (though an external microphone through headphones worked). The step about “enabling headset mic input” seems to have fixed that?