List Of Related Issues? Power On, Fingerprint Reader & Clock Failure

Hi Everyone,

I’ve had some bizarre behaviour and have no idea where it’s come from. One of these issues on its own I could probably solve but together they are a pattern that I can’t seem to fix. For reference, I am running Windows 10, 19045, on the original 14" Framework. The process is as follows:

If the laptop has gone into hibernation or sleep mode, I have to plug it back in to be able to use the power button to wake it up. Long pressing I/O to hard reset the machine doesn’t work nor does pressing the keyboard.

Once I have plugged it in, the keyboard lights up and after booting to the log-in screen it always takes 3 attempts with the fingerprint scanner to unlock. The first time it says it doesn’t recognise my finger, second it ‘encounters a problem’ and third it finally lets me in. The password gets me straight in but I can’t understand why the reader always takes 3 attempts.

Lastly, if I have to wake the laptop like this, the clock is completely wrong. Usually, the time is the time I last put the machine to sleep/hibernation, but it can be anywhere in between as well. In Windows Time and Date I tried using “Sync Now” but always fails, and seems to only update it when it feels like it. It also means that until it updates I can’t reliably open certain websites such as Outlook, Facebook, Youtube etc - I get the text on a white background with no images - I’m assuming this is because the websites require you to be correctly sync’d in order to function properly.

I have attempted fixes for each of these issues individually but they’ve not worked. So any ideas on what could be wrong?


You have the standard RTC coin cell issue in a mild variant, some laptops get stuck even more so they don’t even boot after connecting to power.

Contact support to get a replacement RTC battery (they send them even when you’re out of warranty, as it’s a known issue) and make sure to never unplug your laptop from power for a longer time (multiple days/weeks) and that you let it connected for some time even when fully charged.

There is some work going on for a more permanent fix (that requires soldering a wire to your mainboard) which makes the laptop not need the RTC coin cell anymore.


Thank you very much, Jonathan - exactly what I needed! I guess I have my temporary fix and hopefully, the more permanent fix is easy to do.