Microphone no longer working

I’ve got an 11th Gen motherboard, and I’m running Fedora Kinoite (aka Silverblue, but with KDE) (I’ve tried this on a pinned version of 35 I still have, and the latest 36).

My mic seems to be no longer working. I know it worked at some point after I got the laptop.

The reason I’m making this a Community post to start instead of a Support question is to ask the community a question:
If you have a known working microphone on any Linux, and you run dmesg -w, and flick the hardware switch on and off, do you get messages about a USB device being disconnected?

This is how it works with my web cam (which I can see works), but I don’t get any dmesg output when I toggle the mic. I’m thinking that’s indicating a hardware issue. But I just want a second opinion on what I should be seeing before I start down the hardware route. :slight_smile:

no messages on dmesg -w for me if the microphone is turned off/on, and the microphone works well. I do get messages when the camera gets turned off/on


And that’s with the built-in mic next to the webcam, not one plugged into the jack on the side, right?

1 Like

I had some more time today to poke at this issue while I was rebasing to Fedora Kinoite 37, and I figured it out.

I don’t know if it was a PEBKAC error, or a default getting reset at some point in the past, but it was a KDE setting that needed to be changed.

I had to update the Profile on the Speakers to Analog Stereo Duplex; it had been set to Analog Stereo Output at some point.

I hope this can help someone else in the future. :slight_smile:


Coming back from the weekend, this is a great share!