Occasional Segfaults in Multiple Linux Distributions

Hi all! Finally got some time to setup my Framework (Batch 4) this weekend and unfortunately I keep hitting an occasional weird segfault.

I’ve bounced between both Fedora 34 and Debian 11 and I’m getting the same errors on both which has me thinking maybe this is a hardware or kernel issue? So the issue goes, after about an hour of use I’ll go to reopen Firefox, and it’ll spontaneously segfault. Reboot and it’s good for a while until I go to open a file and nano will segfault. Every time rebooting seems to temporarily fix the issue which got me thinking, maybe I got a bad stick of RAM. So today I pulled out one of the two modules of memory and ran it with one until a segfault occurred. Then I shutdown the machine, switched out the memory module and started it up until again a segfault occurred. To rule out a bad slot, I also tried both modules of memory one at a time in each slot but nothing seemed to work. Maybe I got two modules of bad memory or it’s something in my motherboard? Has anyone else running a Linux distribution experienced periodic Segfaults?


Does adding the below to your kernel arguments help?
acpi_osi=“Windows 2020”

Nope (Fedora 34 and 35).

Yeah, random segfaults on multiple distros almost always points to a hardware problem, and RAM is a great candidate. I’d suggest trying out memtest86 on it - memtest86 is pretty much certain to detect if it’s indeed faulty ram, and both sticks being defective isn’t as implausible as it might seem if they come from the same batch.

Also, have you tried Fedora 35 yet? Lots of people have posted a flawless experience with it, so if this problem is still rearing its head on that, it’s nearly certain to be a result of something specific to your Framework. And when the programs segfault, does it crash the whole PC, or do they run if you rerun them, or will they just keep segfaulting until you restart? Can you start other programs even if one is segfaulting, or will nothing work once the segfaults appear?

Hey all! It turns out that the two modules of RAM I got from Framework were the issue. I replaced them and all seems to be well so far! At the moment I’m running Debian Unstable but I’ve also played around with Fedora 35 and can confirm it’s great too!

1 Like

okay, so that would explain a lot in my case. I just got my Framework yesterday and it is very flakey - random shutdowns. I did not get DIY, but did have to install the RAM. The only thing I ordered was RAM. :frowning:
What is the correct course of action?

@Dennis_Groves Just to clarify, do you mean you got the RAM from them and just had to put it in, or do you mean you ordered the laptop without it and installed aftermarket RAM from like Amazon or such?

I ordered the laptop with the ram, but it did not come installed, rather it came in the bag with my usb-c accessories. I find this acceptable, since the one of the freedoms we used to have with consumer electronics - is the freedom to do it ourselves! Frankly, I am overwhelmed with optimism for a company that trusts its customers instead of extorts them.

I tried the fedora thing, and it ran solid for about 4 hours and then suddenly, the screen goes black and I am back at login. Same problems I was having with not Fedora 35. :frowning: I’ll have to memtest tomorrow and RMA with Crucial if that is the problem.

@Dennis_Groves I can confirm this sounds very similar to what I was experiencing with my corrupt memory modules. If you got two modules you can try removing one and rebooting the system to see if it’s just one module or the other that’s corrupt. In my case they both seemed to be bad but I’d expect that to be very rare. Let us know how it goes!

1 Like

TBH I immediately switched the RAM for 64GB so I can’t speak for the quality or performance of the original RAM.

I am finally back from work and am testing the RAM now.
I am really stoked to get this up and running. :wink:

That didn’t take long. It crashed. and will not turn back on, the power button turns red now.
Okay, now I seem to be really foolish. The mains power has USB plugins but they seem to only deliver about 30W of power? Argh, So now I am using a 90W power brick. My bad.