Intermittent freezes in Linux

Over the weekend I received my Framework and have been working on getting it set up. I purchased the memory and storage separately and it seemed from reading the specs that they should be compatible. However, I am experiencing intermittent freezes while running Linux (I have tried PopOs and Ubuntu 22.04; have not tried Windows nor have it available). The freezes always come within an hour or so of use, and usually less than that. There doesn’t seem to be any connection between anything I’m doing and the timing of the freeze; it happens whether I’m just browsing or doing something in the terminal, and the system becomes completely unresponsive. When I search the kernel logs after rebooting, there does not seem to be anything there indicating that there was any sort of problem and memtest86 comes back clean, so I’m very much at a loss for what to do. I’d hate to have to return the Framework because in all other respects it’s exactly what I need, but having it just seize up randomly on me makes it totally unusable. Looking for any suggestions of what to try.

An update: I tried removing one of the memory modules to see if it would help things. Now instead of freezing, I’m catching reboots within a few minutes of logging in. I guess the problem here is the memory? Going to try to get one of the Crucial modules that are officially supported and see if that fixes things.

edit: the kernel logs after reboot show an error message:

[Hardware Error]: event severity: fatal
[Hardware Error]:   Error 0, type: fatal
[Hardware Error]:     section_type: Firmware Error Record Reference
[Hardware Error]:     Firmware Error Record Type: SOC Firmware Error Record Type2
[Hardware Error]:     Revision: 2

edit 2: I have actually tried both modules separately. One results in freezes, the other in the reboots. Conclusion still seems to be the same: try different memory.

The RAM you linked to says it supports XMP, and Framework says “We recommend avoiding XMP DDR4” on this page here under “What memory is compatible?”. I’m not sure whether this could be the cause of the issues you’re experiencing, but it could be something worth looking into.

4 Likes

Yes, this is true. The thing that made me think it would work was that the G.SKILL website distinguishes between memory modules that require XMP to work and ones that seem to allow for XMP use but do not require it. It’s very possible I struck out there. I’ve got one of the approved Crucial modules coming on Wednesday so hopefully that will fix it.

So, I have now tried the Crucial memory that is explicitly listed as being compatible; I have also tried taking out the NVMe drive entirely and just running the OS from a USB stick. Neither of these work. I get at best a few minutes of usage before the computer completely freezes and stops responding to input. Looks like I’m going to have to RMA the laptop. Very disappointing, as I had high hopes for Framework. I like the idea very much but it’s obvious to me that these boards are not ready for prime time. Maybe in another year.

I’ve never heard of anyone else having these issues so I assume it’s a one-off, the boards are generally fine.

After some more detailed investigation, I think I am 99% confident that the problem is in the video driver. I discovered this by accident by booting into “graphical safe mode” from a USB installer stick, which passes nomodeset to the kernel. At that point, I had total stability and was able to have the laptop running overnight without any problems. Then I tried switching back to loading the driver at boot, and sure enough, I had a freeze within 10 minutes. This is all with the stock 5.15 kernel that comes with Ubuntu 22.04. I’m not sure what the exact problem is here, but it doesn’t seem to be either the memory or the SSD (the G.SKILL memory works just fine).

This is annoying but less of a showstopper for me than a hardware issue. My main use for this computer is development, so running with nomodeset is not a huge issue, as everything that I care about is still pretty snappy. Framework has been kind enough to offer to send out a new board so I’ll see if that one fares any better, but if anyone has any suggestions about what can be done about the driver I’m all ears.

2 Likes

@Jerry_Vinokurov – I think I am having the same issue, both on Fedora 35 and now 36.

It will randomly freeze without any indication of issue. Then does it continue running with fan on high and heat up quickly? Screen frozen the whole time?

I had this happen with the laptop both open and closed, with an external screen plugged in and not, when the screen is locked and not. There seems to be no pattern.

@Thomas_Roderick The screen did freeze for me but there was no fan use nor heating up in my case. Not sure how much that generalizes though. Have you tried booting with nomodeset?

FWIW, I got in touch with Framework support over this issue, and they have sent me a new board. I just got it today and plan to test it out. I’ll report back on whether it fixes the issue or not.

1 Like

So, for whatever it’s worth, replacing the mainboard fixed the problem: I can now boot into Fedora 36 with the proper video drivers and nothing freezes. Thanks to the Framework support team for working with me and getting a replacement board out to me. I can only assume that I simply got unlucky with the one I originally received.

2 Likes