One of my ports stopped working

One of my ports is not working properly. When I plugin a module I get an error message from Windows 10 saying that it has failed to identify the device. None of my modules work in this particular port.

When I go to device manager I receive the following message. " Unknown USB Device (Device Descriptor Request Failed)"

I have tried uninstalling and reinstalling the driver and the problem still persists. I have updated to Bios 3.07 and the latest drivers from 12/15.


Does it continue not to work after a reboot? I had my rear left port stop charging this morning, but the front left was working. I shut the machine down, waited a few minutes, and upon restart it was working fine. That’s the first time that I ran into anything like that, I assume (I hope, I should say) that it was a software fluke. If you continue to have issues you could see if the steps here help:

Good luck, hopefully it’s something simple.

1 Like

I have continued troubleshooting. Rebooting did not solve the issue. I opened up my laptop to make sure EMI sticker was positioned correctly, per the above link, and it was. I cannot get data to work from the problem port. Below are some interesting pictures.

The laptop will not charge when directly plugged into the problem port.

The laptop will charge directly from a working port.

The laptop will charge from the problem port when the charger is positioned a certain way???

The laptop will not charge from the problem port if the charger is facing the other direction.

Confirmation that the charger will charge no matter the direction in a properly working port.

When I plugin any other module, besides USB C, to the problem port this is the message I receive from Windows.
usb b

1 Like

At this point it really sounds like you should start a support ticket.


Oof. I’m not a hardware engineer, but I am wondering if the pins are not properly connected, so things work in one direction but not the other. If you plug a USB-C card into that slot, what happens if you then plug one of your other cards into it, both in a “normal” and in a rotated-180-degrees orientation?

Also, if you happen to have a usb-c extension cable, can you get the cards to be recognized by plugging into it and testing both orientations - no rotation, and flipping it 180 degrees, since you can’t rotate the actual expansion card itself.

These steps may be of use to Support, as at this point it seems like you will need to open a ticket with them.

I was planning to open a support ticket. Figured I would update the post for the curious.


For my cell phones, I have some usb-c cables that I have to flip over to ensure a good connection.
That’s probably wear and tear.
In your case, possibly some misaligned pins so good contact in not achieved.

Having this exact same problem doesn’t matter if i use two different usb-c modules so it looks like it’s that specific port on the motherboard. Did you get this resolved?

1 Like

Same boat, just wrote to support.

they ended up sending me a new mainboard. Working well now.

1 Like

Same here.

Did you have any issue with connecting the display cable?

I have exactly the same issue with the same port on probably the same generation of hardware - 11th gen.

Did you have to send the old motherboard back? I can’t afford to not be able to use the laptop every day.

Maybe it’s just me, but I only started having this issue when I had a USB-A port in each of the slots nearest the front of the laptop. The problem went away when I put one USB-A port in the back-left, and one in the front-right.

I am also having an issue with a USB A port - this is the front left port for me. It goes through periods of working and then just stops. It seems to be the location rather than the port as I have switched the USB ports around and have the issue in the same location. Also on an 11th Gen.
Did anyone find a fix for the issue?

Once in a while my rear left port flakes out. I have been able to get it working again by shutting down the machine, removing power, letting it sit for two or more minutes, then plugging back in and rebooting. While mildly annoying, it is rare enough that it has not become a huge issue in my particular case. What generation machine do you have? In any case, I would suggest opening a ticket with Support so that they can log the issue and work with you to address it if need be.