Palm Suppression Settings insufficient on Linux

Hi all,

I am getting a lot of palm interference issues on Linux. I have had this issue on Mint, Manjaro and Fedora. Are there any settings I can tweak to increase palm rejection at certain corners of the touchpad?

I have a “Disable touchpad when typing”, but the delay isn’t sufficient.

1 Like

I’ve been having this issue on KDE for awhile, I’m running on Arch. I always assumed I had a setting a bit wrong, but am open to the possibility that there is another issue at play.

I’ve been working on this problem off and on for the past few months. If you enjoy deep-diving on this type of thing for the benefit of all, come visit us at or even if you just want to follow along and cheer.

I don’t yet have a solution, however I suspect that it is possible to get better palm detection working through the libinput stack, which may explain why Windows seems to have better results here.

Ideally, I’d like to use this awesome touchpad without DWT (Disable While Typing)–especially in games and other complex combined input scenarios (e.g. holding spacebar + touchpad won’t work in Miro).

It doesn’t sound like you’re having an issue getting DWT working–it sounds like you’d just like to tweak the parameters. I’m not sure if libinput allows that, but it may be possible with a “quirks” file or custom hwdb entry.

For anyone trying to get DWT working at all, please see this post: How to Diagnose Disable-While-Typing Issues | The Linux Touchpad Dev Guide