PSA: Kernel 5.18.0 kernel panic on Arch

Yesterday kernel 5.18.0 came out on Arch. After upgrading and rebooting my system immediately went into kernel panic with messages that it could not load some kernel modules. But at the end it still booted. Looked it up and a lot of systems with 11th and 12th gen intel cpus are having this problem.

To solve the issue you need to add ‘ibt=off’ as kernel parameter. Thanks to this reddit post.


For everyone else: If you have an Intel 11th or 12th gen CPU, have NVidia graphics, and are running kernel 5.18, you’ll need to set a kernel parameter to get a stable system for now.

To find your kernel version, run: uname -r To find your CPU: cat /proc/cpuinfo | grep 'model name'

Why? Well, Intel put “IBT” or “Indirect Branch Tracking” into their 11th gen and greater chips. Linux is now supporting it, but NVidia’s drivers are not compiled for it… yet. This is to help prevent side-channel hacking attacks.

AMD uses different methods to do the same thing.

Even though Framework doesn’t have a Nvidia gpu it is still affected by this issue, and adding the kernel parameter solves it.


I’m not experiencing any issues with the 5.18.0 kernel on Arch.

I saw the same panic / failure to boot due to hanging kernel module loading on 5.18.0-arch1 as well (even when my nVidia eGPU is not connected). Using Nvidia-dkms 515. something currently to provide Nvidia drivers.

Adding your boot parameter fixed it. Thanks for the PSA!

1 Like

Thank you so much! I’d been having issues lately with my personal Framework just randomly shutting off for no reason whatsoever. I kept putting off investigating it until it started happening to my work one too. It sounds like this should fix it. I’ll be sure to follow up if it didn’t.

Just wanted to follow up on this. I’ve had the ibt=off removed for a couple of weeks now and I think this seems to have been resolved. Can anyone else confirm?

I am running the latest Fedora 38, and recent kernel updates have caused this to occur.