Random question - has anyone here tried to run Elden Ring in Linux using Steam Play?

If I can get it to work I will post steps here. I may have to tear it down and start over as the walls are covered with pasta at this point, figuratively speaking.

I’m on Pop!_OS 21.10. It launches fine if I reboot into Windows. In Linux the best I’ve been able to do is to get it to launch, and I have audio, but only a black screen. I’ve glanced at the logs but may have to take a deeper dive if I don’t get anywhere with it. I have the same outcome in Wayland and X.

Any and all suggestions welcome, including smart-alec remarks.

Did you try running it with Proton Experimental or Proton GE?

Yes, I have tried Proton experimental, including bleeding edge, and the GE versions. GE 7.3 allows it to launch and play audio, but thus far no video.

1 Like

The ProtonDB page has people getting it working. I would check there to see if they have any flags that they enabled to get it to work.


@zmk5 - thanks for the note.

I have been following that and the open bug report on the proton github. The best that I’ve been able to do so far is to get the game to launch with audio, but a black screen. That leads me to believe that it could be a driver issue with the gpu and proton, since the game runs (well, launches at least - I haven’t actually played it) in Windows. On a separate note, when I refreshed the protondb site the sidebar on the right with the systems specs for each report is no longer present. I’m hoping that I somehow changed a setting and that it hasn’t been hidden overall.

I’ll post an update if I ever get it working.

…am I missing something? From news I’d been reading, I thought my gaming desktop PC (i5-7500, AMD RX 480, 8GB RAM) wouldn’t be able to run Elden Ring. Are there reports of any laptop without dedicated graphics cards running it?

Seems latest GE-Proton7-9 has a fix for Elden Ring, that might help you too. The fix is not specifically for Xe, but still:


  • Set VKD3D_FEATURE_LEVEL=12_0 by default. This allows some older AMD GPUs to get past the “white screen” bug in Elden Ring

You can probably use that environment variable without upgrading.

Update for those playing along at home. The game runs fine on the machine under windows. I’m not very good at it, but that’s not relevant here…I rebooted to manjaro, installed the development mesa-git drivers, and the game launches in online mode, but crashes at the character creation screen. In Pop!_OS I had to make a change to increase the priority of the dev package, see here: https://www.reddit.com/r/pop_os/comments/lbhdeg/kisak_mesa_ppa_not_updating_mesa_packages/. There the game starts, but in offline mode, and hangs up at the character creation screen.

I then played and saved in windows, and attempted to load in linux, still no dice.

All was done with GE-Proton-7.9, which needs the proton script modified due to a typo, see comment from GloriousEggroll here: Elden Ring (1245620) · Issue #5613 · ValveSoftware/Proton · GitHub

Will keep testing periodically to see if any updates to the graphics drivers, proton, or the game make a difference. Thanks to all for the input!

1 Like

Having the exact same issue here. Rarely get a black screen with audio, mostly just a straight CTD. No solution yet, will post if I find something that works. I’m at the point I’m nearly ready to shell out money and get the malware that is Windows :frowning:

Update - it is working now with GE-Proton-7.13, mesa-git, and the invisible enemies patch from here: INVISIBLE ENEMIES BUG FIX at Elden Ring Nexus - Mods and Community - which seems to slow the frame rate but it does work.