Razer Core X Chroma eGPU Lockups

My i7 Framework completely locks up within an hour (usually much less) of use on the eGPU. I have to force shutdown. It worked great for the first few weeks. I’ve tried changing the power setting in the NVIDIA control panel, but that didn’t make a difference. Fresh reinstall (Win 10 Home), drivers, few apps, no change. I’ve tried multiple ports, and am currently cycling through them to make sure it happens on all ports (so far, it does). Updated BIOS to 3.06, no change.

It looks like Razer is going to want me to mail the Core in for repairs, but I thought I’d post here in case someone had an idea.

Apps I remember installing:
Steam (and a couple games)
Razer Synapse
Docker Desktop

Update: front right port doesn’t even work properly. The hub works but not the GPU itself.


Do you need to use Synapse to use the eGPU dock? That software is terrible and caused numerous issues with framerates on my gaming desktop. I would try using it without synapse running to see how it is. I love Razer products but their software leaves a lot to be desired. Also, does it work on different operating systems? Windows for example?

I would say that your experience is indicative of a hardware problem somewhere. I have had no issues whatsoever with my Sonnet eGPU enclosure housing both NVIDIA and AMD cards, both directly attached and through a CalDigit Thunderbolt dock.

Hope you are able to get it sorted!

Same results as @Eric_Busch here. My Sonnet doesn’t use any 3rd party software so it works all the time, every time with any card as well as docked keyboards, Mice, Drives etc.

This may be something you’ve known already for a while, but I believe you have to set your display adapter (for the eGPU) to max performance or something like that in order to prevent weird behavior and lockups with the eGPU.

I read that under the eGPU thread as I have a X Chroma coming in as well.

@Matt_Upwood I am using Windows. I’ve tried with and without Synapse. WSL is Windows Subsystem for Linux. I can run an Ubuntu terminal from inside Win10. Tbh other than the possibility of a hardware issue, I’m kinda suspect of WSL causing the issue. I plan on one more fresh reinstall without WSL.

@2disbetter Right, that’s the power setting I mentioned. Changing that had no effect.

Have you changed the PCI and USB power management to make sure the device cannot be shutdown to save battery ?

Do you have another thunderbolt laptop/desktop you could test the eGPU on?

I tested with a Dell Thunderbolt laptop, and the issue persisted

I did another reset and didn’t install Docker Desktop, WSL, or Ubuntu, and it’s been working pretty solid since then. I haven’t tested further, but I suspect something to do with WSL.