[RESOLVED] Backlight on brand new framework suddenly stopped working

Hey there,

I have a brand new framework intel 13gen laptop on which I set up ubuntu 22.04 a couple of days ago. I followed the really comprehensive guide (Ubuntu 22.04 LTS Installation on the Framework Laptop 13 - Framework Guides) step by step and everything worked fine for almost a week. The Brightness adjustment worked and the fingerprint aswell. Today when I turned on the laptop the backlight was suddenly not there anymore. With a flashlight you can see parts of the display that are white but the backlight seems to be completly turned off.

I have been coding for years but I am rather new to the linux environment and I have no real idea about the boot process etc…

What I did so far:
I already checked all cables which seem to be fine. I also checked my /sys/class/backlight folder which has one entry intel_backlight. When I print out the brightness I can see that I can still adjust it with the corresponding keys but this has no effect since the backlight is still off. I also tried to add the acpi_backlight option to grub config (vendor, native, video) which did not work.

I found this similar issue ([SOLVED] Backlight brightness issues - #7 by Matt_Hartley) in the forum but it did not solve my issue. If anyone has any idea what I could do next I would greatly appreciate your help!

Best Yannick

Update: The screen backlight startet working again after a couple of days without me doing anything. I am really not sure if this is a hardware or a software issue…

Welcome to the community!

Appreciate the update, definitely not the experience we want for you.

So long as we’re sticking with:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash module_blacklist=hid_sensor_hub"

in /etc/default/grub with sudo update-grub, reboot done after, you are then setup correctly. Further details here.

All of that said, I want to clarify this:

This feels like one of two things:

If it happens again, and you have tried the above, please open a support ticket and link to this thread.

1 Like

Unfortunately the screen/backlight suddenly stopped working again. I unplugged the battery and display as mentioned above and also checked my grub settings which are correct.

I really have no idea if this is software related or a hardware issue. I opened a support request as stated above. Thanks for the help so far!

Does it do it when booted from live OS media ; try the Fedora 39 ISO / Installer

As someone who is a hardware engineer, I would say the supply that powers the backlight has an intermittent fault. Probably a duff solder joint somewhere in the backlight panel to get the symptoms you describe.

Framework replaced my screen and it works flawlessly now! When replacing the screen I noticed that the connector underneath the screen / bezel (not the one on the motherboard) seemed like it was not that well connected (I did not check that before since it was mentioned nowhere and I was kind of afraid to disconnect the display since I am not that experienced with hardware). I am not sure if that was the issue but just wanted to drop this here in case that helps anyone else / reduce request to the support team :slight_smile:


Hi @Yannick_Pfeiffer, Thanks for the update :slight_smile: , marking this as Resolved.