[RESOLVED] Disabling the Framework UEFI splash screen on boot with Fedora 39

Hi folks. So I’d like to disable the Framework splash screen that shows up on boot. Currently running Fedora 39. I’m not talking the BIOS splash screen but the one after GRUB takes over.

My linux is rudimentary at best, but as best I can tell UEFI is handing that off to the OS and it’s being displayed on boot.

I found

tl;dr I added the following to GRUB (Also tried removing quiet just to see what happens.)
GRUB_CMDLINE_LINUX=“rhgb quiet video=efifb:nobgrt fbcon=nodefer”

that doesn’t seem to work. Normally on my desktops I can disable this feature. (At least in Asus motherboard.) I’m not seeing that option in the BIOS for the FM 16.

Any thoughts or help would be appreciated. Thanks.

This is a feature/configuration of plymouth so you can probably change the plymouth theme.

Alternatively, try adding bgrt_disable to your kernel cmdline.


Shouldn’t removing the “rhgb” option do precisely that? That is the option to show the graphical boot screen instead of the normal kernel and boot log.

Also what does the BIOS have to do with what the OS shows while it is loading. That should purely be an OS option. And anything in the BIOS that influences that, probably only does so as a byproduct of some other changes.

Its a feature with UEFI. I don’t understand it but you see it with Windows as well where the normal boot screen is overridden with whatever the OEM has set up. My desktop has an option to turn this off in the BIOS. Not an option here.

This worked. Thanks.

The logo format is standardized. And the driver the UEFI provides to the OS gives them the option to access that standardized logo and use it. It is their choice. Both have options to override that with custom logos I believe.
If the BIOS prevents that it is ether not booting in UEFI mode, not using UEFI GPU drivers or on purpose hiding the logo from the driver.

Marking resolved.