[RESOLVED] Error when trying to live boot ubuntu 22.04

Hello, i am mainlly using Windows on my framwork but i was currious to see how well ubuntu would run on the laptop.

i dowloaded the UBUNTU 22.04 iso from the website and try to put it on a usb stick with Ventoy. for reference i later try on another USB stick but juste the iso burn with Rufus. and i got the same error messages.

i firstly encounter a problem with the secure boot so i disabled it on the BIOS.
However i encouter this SQUASHFS error (see picture) when i try to live boot from both my USB stick (one with ventoy and the other the iso burn with rufus)
i did not find any solution online, most people seams to have install ubuntu on the framwork without any issues when secure boot is disable…

Am i missing something ??
thank you in advence.
also you might have guess that english is not my first language lol.

It says squashfs is “probably corrupt” in the messages. This is the operating system image being extracted from your bootable media.

When installing linux this is a common problem. You should do some troubleshooting:

  • verify the iso you downloaded (I usually torrent them to avoid corruption, wifi can also be a problem- perhaps you can use a hardwired computer to download your live cd…) see here: How to verify your Ubuntu download | Ubuntu
  • is this an old USB key? They can be problematic… do you have any others you can test with?
  • if these fail, you might alternatively try using using a different port on your FW. See the port matrix - try using a different rated port.

Installing linux is still not without its occasional hiccups. Best of luck.

Last thought: my preference is Balena Etcher for all systems. I have not always had success with Rufus.

As to the ACPI BIOS error… are you running the latest BIOS?

See here… https://www.reddit.com/r/Ubuntu/comments/x3g67g/how_to_solve_acpi_bios_error_ae_not_found_tried/

Had some similar issue while trying to install Ubuntu 23.10. To get around, I used Ventoy. However, before i installed Ventoy and copied the Ubuntu ISO and other OS ISOs, I formatted the USB to exFAT.
The Ubuntu ISO is larger than 4GB. Think that may be the reason why it isn’t loading/booting from the USB when formatted as FAT32.
I could be wrong on this deduction.
The following is my Framework 13 AMD with rEFInd.

P.S. replaced Ubuntu with Debian 12 in the last week. Setup still same. All FW ubuntu support works on debian 12 too.

Thank you Framework team. My best laptop purchase ever, coming back for FW13 Intel. Cheers!!

Hi @Xavier_Brosseau, welcome to the forums,
Do try balena etcher when writing ISO to usb, and make sure the downloaded ISO is good by verifying its md5 sum. :slight_smile:


Hello, sorry for the late reply, i Finaly manage to make it work and i will try to resume what i think happened.

For my first test i used Ventoy on my Green USB Stick and put ubuntu on it.
it did not work so i figure it might be my USB stick that might be broken so i took another one (will call it Black) and put ventoy on it.
however to save time on downloading the ISO, i juste took it from the green one directly to the black one.
I then got the same broken result then i wrote to this forum about the issue.

I figured out that my green USB stick was on his last breath and the ISo must have been corrupted when put it on this nearly dead USB Stick. That also explain why i got the same result when i put the now corrupted ISO to the fonctionnal Black usb stick.

In the end i used a new ISO that i downloaded with bittorrent has suggested, And I put it on the black usb Stick with Ventoy and it work like a charm.

For the Green USB stick, it died peacefully while trying to format it back to a normal Fat32. RIP

Thank a lot for your help.

1 Like

Thanks for taking the time to update your thread and describing what really happened and how you resolved it. :slight_smile:

1 Like