[RESOLVED] Fan is constantly running at high speed from boot to power off

Hello all,

I’m having a problem with my Framework’s fans. Starting about a month ago, every time I power on the laptop the fans ramp up to what sounds like max speed and never stop spinning until I power down the machine.

Laptop: 11th Gen Intel(R) Core™ i7-1185G7
OS: Ubuntu 22.04.1 LTS
Kernel: 5.15.0-56-generic

I tried following the tips found in this guide [Linux] Fan speed controller with custom speed curve but that did not work.

I also tried using the ectool command from this repo and setting the fanspeed to 0 manually but that did not work either.

Here is the output from lm-sensors, so it seems like the cpu temp/sensor isn’t the issue.

kevin@kmk-framework:~$ sensors
Adapter: ISA adapter
Package id 0:  +35.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +29.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +30.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +30.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +31.0°C  (high = +100.0°C, crit = +100.0°C)

Adapter: ACPI interface
in0:          14.54 V
curr1:       689.00 mA

Adapter: Virtual device
temp1:        +31.0°C

Adapter: PCI adapter
Composite:    +31.9°C  (low  =  -5.2°C, high = +83.8°C)
                       (crit = +87.8°C)

Adapter: ACPI interface
temp1:        +40.8°C  (crit = +210.0°C)

Any help would be appreciated! I’m a college student so having my fans spin 24/7 while in class is very distracting.

  1. Try to use the newest kernel you can get for your Ubuntu install. 2. Check and see if you have thermald installed. If not install thermald with dptfxtract, and enable both services this will create an automatic thermald profile which will help provide a good thermal envelope for your laptop. 3. Remove gnome-power-profiles, disable it and remove it. Then install TLP and configure it. Disable turboboost on battery. This will help you have the best battery life you can get, and together with thermald and a newer kernel will help bring your fans under control. 4. Lastly undo anyting you may have done already as it may be contributing to your issues.

Not sure if this is related, but I just checked the thermald status and got this

kevin@kmk-framework:bin$ sudo service thermald status
● thermald.service - Thermal Daemon Service
     Loaded: loaded (/lib/systemd/system/thermald.service; enabled; vendor preset: enabled)
     Active: active (running) since Mon 2023-01-09 19:08:33 CST; 29min ago
   Main PID: 1289 (thermald)
      Tasks: 4 (limit: 38179)
     Memory: 3.3M
        CPU: 440ms
     CGroup: /system.slice/thermald.service
             └─1289 /usr/sbin/thermald --systemd --dbus-enable --adaptive

Jan 09 19:08:33 kmk-framework thermald[1289]: sensor id 10 : No temp sysfs for reading raw temp
Jan 09 19:08:33 kmk-framework thermald[1289]: sensor id 10 : No temp sysfs for reading raw temp
Jan 09 19:08:34 kmk-framework thermald[1289]: Unsupported condition 58 (UKNKNOWN)
Jan 09 19:08:34 kmk-framework thermald[1289]: Unsupported condition 58 (UKNKNOWN)
Jan 09 19:08:34 kmk-framework thermald[1289]: Unsupported condition 58 (UKNKNOWN)
Jan 09 19:08:34 kmk-framework thermald[1289]: Unsupported conditions are present
Jan 09 19:08:34 kmk-framework thermald[1289]: Polling mode is enabled: 4
Jan 09 19:08:38 kmk-framework thermald[1289]: Manufacturer didn't provide adequate support to run in
Jan 09 19:08:38 kmk-framework thermald[1289]: optimized configuration on Linux with open source
Jan 09 19:08:38 kmk-framework thermald[1289]: You may want to disable thermald on this system if you see issue

I’ve tried enabling TLP with the settings you suggested, but my fan is still spinning at full speed all the time. Could it be a hardware issue?

I doubt this is hardware outside of not having a new enough kernel running on it. I would definitely look to see if there is a way to run either the 5.18 kernel or 6.0 kernel on Ubuntu 22.04. Also verify dptfxtract is installed and that the service is enabled/ runs when thermald is started. The issue you are seeing with thermald suggests that it is but it is not generating the thermal-conf.xml properly. My suspicion is this is because of the older kernel. Also remember to run systemctl daemon- reload and systemctl restart nameofservice after any configuration changes.

And I just noticed you are on an 11th gen. Do you have the latest bios installed?

Does this mean that when the machine is powered completely off, and you start it, and cold boot, that the fan is ramping up before the laptops posts (you see the Framework logo)? Basically, the fan starts nearly as soon as the laptop turns on, and before it has had time to load anything?

If so, this speaks to a hardware problem. Most likely you need to re-apply thermal paste.

If this is NOT the case when cold booting and your fan ramps ONLY after you begin loading the OS, then it speaks to a kernel and software issue.

Don’t think it is going to be a paste issue. The temps are likely too low for that. Temps in the 30C range would not be happening with the kind of.bad paste job that would cause it to kick on quickly and stay on. The temps would be my ch higher, and there should be peaks and valleys in the fan curve. This is looking more like a bad thermald-conf to me, at least right now.

I had issues with temperatures in the beginning on my laptop as well. I went into the BIOS and disabled all the Intel Power settings and left it on “Max Non-Turbo Performance”.
(Disabled SpeedStep, Speed Shift, Turbo-Boost

Since then, never had any thermal issues again.

You should not have to cripple your laptop to get the fan to calm down. Disabling SpeedStep and Speed Shift shoud not be necessary as well as Turbo-boost.

You’re right. In fact I’ve turned them back on.

So my situation was:

  • Got a framework DYI without OS
  • Plugged in SSD and NVME, booted and laptop went hot (fans, CPU)
  • Heard on the forums that disabling Intel specific settings works
  • Disabled Intel settings on BIOS
  • Installed OS on NVME (Void Linux)
  • Installed microcode and set it to start early in boot
  • Upgraded Firmware from Framework and NVME to latest
  • (And today) enabled Intel switches back on. So far looks alright. No heat, no fans and low CPU usage.

So far it’s well, let’s see if the craziness comes back later.

I think after troubleshooting this seems like a hardware problem. For one, the fans run at full speed even in the BIOS menu so that rules out Ubuntu power management problems. I tried turning intel BIOS power settings to max battery and disabling speedstep, speed shift etc and that did not work either. I’ve also noticed that sometimes the fans will stop, but that is only briefly and not often.

I’m not sure why the kernel version or other software issues could be the problem, I’ve run this laptop with Ubuntu for over a year now without issue until about a month ago.

Thanks for your replies, any other help would be greatly appreciated!

More weirdness. After changing the cpu settings back to turbo bost etc, the next boot didn’t have the fan spinning. After about 5 minutes of using the laptop, the fan started spinning again and hasn’t stopped. So, maybe it is software after all? Will try updating the kernel.

What happens if you boot from a live image on USB? If the fans are still spinning up then that may help to point away from software towards hardware. I would make sure that the machine was cool before commencing such a test.

It would be good to do a cold test (let it cool down for hours) without the nvme with a live ISO (as suggested above) to make sure we really have a hardware issue.

I echo this advice completely.

Sorry for the late follow up, but here is where I am at right now. The fan is still spinning out of control. I tried removing the nvme drive and booting into a live usb both on arch and on ubuntu and the fan still spins. It starts spinning the moment the laptop is powered on. I opened it up and took the fan and cooler off and noticed that there was some dust and hair in the intake so I cleaned that off and reinstalled the fan but the problem persists.

Should I just order a new fan and heatsink?

Did you repaste it?

1 Like

I just kept the paste that was already on there. Would that make a difference with the fan though? The cpu temps are not a problem, the output of sensors gives me 36 C as the core temps.

Yes that would likely make a huge difference…if you repaste it and it is still behaving that way you have eliminated essentially all the things you could do. At that point it is very likely there is something wrong with your hardware.