[RESOLVED] Fwupdmgr BIOS Update from 3.06 on 11th-Gen Arch Linux

Hi folks, I am trying to update my BIOS from 3.06 to 3.17 using fwupdmgr on my 11th-Gen DIY Laptop running Arch Linux.

The core issue seems to be that “System Firmware” is listed in the “Devices with no available firmware updates:” section, so when I run fwupdmgr update there are no updates. Any idea how to fix that?



I was able to work around this by downloading the .cab from LVFS and running fwupdmgr local-install. The BIOS update itself progressed fine, although I’d still be curious if anyone knows how I can get fwupdmgr to recognize the association between my “System Firmware” and the firmware posted at LVFS: Laptop 11th Gen Intel Core

Welcome to the community!

I’ll mark this solved as you were able to installed using a local cab install approach.

In looking at your screenshots, I believe this may have been the missing piece:

fwupdmgr refresh --force


fwupdmgr get-updates

Noticed this missing in the Arch wiki, but we do list it for our own two officially supported distros.

As to why fwupdmgr didn’t find your update: note that of all framework updates:
only the Ryzen 7040 is listed as “stable” for its state. All the other updates are in “testing” state. By default fwupdmgr won’t look in the testing stream. You need to activate that explicitly. This is unexpected because normally you’d expect an update to move from “testing” to “stable” once the update goes out of “beta”. Framework didn’t do that with most of their updates.

[EDIT: I see in your screenshots that you did have testing activated. Leaving this comment here for posterity, since this is something other people will likely stumble over until Framework gets the confidence to push updates to stable]

1 Like

OP was on 11th gen. :slight_smile:

Absolutely agree, yes, the comment is solid.

Edit: As Nils kindly reminds me (it’s been a long month (even at the 8th), appreciate the eyes).

Anything not on stable, will need testing enabled. To enable testing, see our doc.

@Matt_Hartley , @Nils , thank you both for responding.

Just for completeness:

  • I had run fwupdmgr refresh --force many times, with no effect
  • I had enabled the lvfs-testing remote (as Nils later noticed)

So the root cause is still a mystery, IMO

EDIT: To expand on the above, this fwupd Issue contains the definitions for each state, and “Devices with no available firmware updates:” (which is what my machine shows for ‘System Firmware’) means

This device (or its manufacturer) was not found on LVFS. So we cannot ascertain whether the device is outdated or not. Example: You have a Samsung 980 Pro. Samsung is registered, but the 980 Pro isn’t in the database. Or you have a WD Black, and WD isn’t registered.