[RESOLVED] Laptop froze then string of command buffer timeout, no longer booting up OS

Hi guys,

I ran into a snag with my laptop while watching some videos this evening. The system froze then received a string of errors. See AMD-Vi screenshot below.


After trying to reboot, it just displays what(I think) is a shell command line area.

I’ve tried holding down the power button for about 30 seconds after but still runs into same issue (seeing Framework logo then that shell command line).

Any thoughts? I’m wondering if my SSD is pooched or if something else is amiss.

Thank you in advance!

1 Like

SSD is probably fine otherwise you’d probably land in the BIOS and not at a Linux command prompt.

Try running the following. What does it return?

mount -a

It returned nothing save for a new line

Tried Mount -a and got an error

Oh, looks like your filesystem might be corrupt. Check out this guide that might help you repair it.


Thanks for this information, @cmstew!

With the fsck commands/information in the link you provided, it seems to be fixed. I’ll continue to monitor this but really confused as to how this all happened in the first place.

I’ve learned over the years that as soon as a hard drive shows any weird issues (even a single flipped bit), the drive shouldn’t be trusted. Of course, it’s possible the issue was caused by something else (such as a software error), but I’d make sure that everything of value is backed up (as it should be, regardless).

1 Like

Here’s another guide from my prior employer that may help you as well. Booting to a Pop live USB to repair the Ubuntu install is absolutely an option:

1 Like

Thanks @Alex_S and @Chris_Snyder

As for backing up data of value, thankfully I had backed up everything to another system before switching to this laptop. There are some new things that are on this laptop (which I value) which I’ll be backing up this weekend so my work isn’t lost.

Thank you again everyone for your help and insight. I wasn’t too sure that anyone would be able to help with this matter or give advice but was grateful you piped up.


Huge thank you to @Alex_S and @Chris_Snyder - marking resolved.


I just run into the same issue and now my file system is completely unrecoverable :frowning:
Some additional info:
Ubuntu 22.04 with kernel 6.7.0 from xanmod
I got the same errors (AMD-Vi: Command Timout), machine froze, file system broken on reboot, no way to fix it.
Looks like some bad interaction between amdgpu and amd-vi.
This is quite serious…
Brb, I’ll have to recover from backups

@Matt_Hartley please add this to the list of know issues

Please use the recommended kernel for LTS from the guide. We don’t test against 6.7.0 from xanmod.

I do appreciate you letting us know, however.

Yes, I was aware of the risks, but this is the first time in quite a while (10 years?) that things went catastrophically wrong. It’s also true that I was using a very/old stable machine before (x230).
Never the less, I feel that there is something wrong in the latest kernel versions (if I search for AMD-Vi errors there are more than a few open threads).
I will use the oem kernel for now, although it’s missing some nice quality of life improvements related to amdgpu, amd_pstate, and so on…