[RESOLVED] No HDMI Audio Out Devices Available

I have been doing a lot of testing between machines and displays to make sure I wasn’t missing something but I do seem to have an issue getting HDMI Audio out to register on any device I plug into. If I use the HDMI adapter, I do not have an audio device present itself to the operating system. I have a portable USB-C monitor that presents audio out to my HP EliteBook 840 G7 (10th gen Intel) but not to my Framework. Just to test, I did remove the USB-C cards and plugged the display directly into the Framework but with the same results.

When I dig into the system, I do see that there are provisions for HDMI out but they are showing as unavailable.

I can list the alsa devices in the terminal as well

> aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: 92HD95 Analog [92HD95 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

At this point, I am stuck. It appears to be some sort of bug with the Framework itself. Or, it is possible that something has changed with the 13th Generation that is causing these troubles. Previous related posts give me the impression that the problem was worked out.

Any help on this would be greatly appreciated.

The 1st HDMI Output seems to be available

Well… it’s not. There is no audio out of any HDMI outputs to anything plugged in. It can be a dock, or directly plugged into an expansion slot and nothing. I cannot direct any sound from any HDMI port.

I have also started a thread on the openSUSE forums concerning this issue. I am hoping to be able to track down whatever the problem is for the benefit of anyone.

Hi @Nathan_Wolf

what does pactl say?

pactl list short sinks

52      alsa_output.pci-0000_00_1f.3.analog-stereo      PipeWire        s32le 2ch 48000Hz       IDLE
833     bluez_output.00_14_BE_35_66_75.1        PipeWire        s16le 1ch 16000Hz       RUNNING

I hope that helps!

I have submitted a bug report with openSUSE as well:


I would like to get this working with my distribution of choice! :slight_smile:

1 Like

Good initiative @Nathan_Wolf ,

But have you tried Ubuntu live 22.04 and perhaps Fedora live 38, see if it works there or still exhibiting the same symptoms same as openSuse?

might be useful to get pulseadio version if they have different results

pulseaudio --version


I am running the newer Pipewire audio server.

Compiled with libpipewire 0.3.77
Linked with libpipewire 0.3.77

I can see about trying another distribution, perhaps install off of an SD Card or something.

Ultimately, I want to get openSUSE running on it so I will work to that end. I think trying another distro might shed some light on the issues too.

Thank you!

1 Like

This is now resolved as of openSUSE Tumbleweed Snapshot 20230922 running Linux Kernel 6.5.4-1. The full bug report can be seen here and it is now marked resolved. There are no issues with audio on openSUSE Tumblewed.

The Framework laptop is

1 Like

Thanks for updating this thread @Nathan_Wolf , appreciated. :slight_smile:

1 Like