No HDMI Audio in Manjaro

Just got my framework laptop today (i5). Right now I’ve got Manjaro 21.1.6 with KDE.

When using the HDMI expansion to connect to my TV, I get video output just fine, but no audio out through the HDMI. Poking around in alsamixer didn’t show any HDMI audio devices, and doing aplay -l also didn’t list the HDMI expansion audio out. (Though, it did list plenty of other HDMI audio outputs, just none were the right one).

Does anyone else have this issue? Or am I just missing something?

Sorry for the double post. Just posting some more investigating. It seems that the HDMI expansion uses USB-C Displayport alt mode, and simply uses an onboard IC to convert from DP to HDMI. The IC is the PS186HDM. Knowing that, I gave the displayport expansion a try on one of my monitors that has built in speakers and no dice there. For now this seems to be outside my skill range for linux troubleshooting.

I had to manually switch the “profile” in pavucontrol (the last tab) to be HDMI output + Analog input and then HDMI sound output worked. I wish it would automatically switch, but this is still a step up from my previous laptop which had an Nvidia GPU which outright failed to send sound through HDMI (no matter how many times I fiddled with PulseAudio).

1 Like

No dice here. KDE doesn’t have pavucontrol (I assume that’s the XCFE volume manager)
I did find something similar in KDE’s equivalent, but none of the HDMI options give me actual sound.

Either I missed a device when testing earlier, or an update fixed it. Following Chiraag_Nataraj’s advice, I was able to manually switch profiles. For those using KDE, go to Audio in the KDE settings manager.

This is now solved

Sorry for the triple post. The above solution isn’t as clean as what I prefer. I like to be able to quickly switch output devices using the volume control widget, rather than navigating all the way to the system audio settings. Adding a custom alsa profile allows for this.

in the file /usr/share/pulseaudio/alsa-mixer/profile-sets/default.conf

add this to the end of the file
[Profile output:analog-stereo+output:hdmi-stereo+input:analog-stereo]
description = Analog Stereo Duplex + HDMI Stereo out
output-mappings = analog-stereo hdmi-stereo
input-mappings = analog-stereo

This will create a new profile that exposes both the analog speakers, as well as the HDMI audio

pavucontrol is not specific to any specific desktop environment and can be installed by your package manager, it provides a little bit more configuration than your standard volume manager and doesn’t conflict with it at all

I’ve used pavucontrol before (back when I used XFCE actually), but I wanted to try making what KDE had work. Though, I admit, it was more work.

But the built-in mixers tend to really, really suck in terms of control. There’s no reason to limit yourself to it when pavucontrol works quite well and gives you a lot of control.

1 Like