[RESOLVED] USB A expansion cards no longer working after plugging in a third

Issue is as described in the title. I’ve been using my Framework laptop with two USB A cards, an HDMI card, and a USB C card for some time now. I recently decided that I need another USB A port more than I need the HDMI, so I ordered another card and plugged it in. Everything seemed fine at first, but when I tried to plug something into the third USB A port, all of my USB devices disconnected. Now none of my USB A ports work.

I’ve tried all three expansion cards in every slot and none of them seem to work with any of the devices I’ve tried to plug in (which all work on other machines). The USB C card still seems to work fine in all slots, suggesting it’s just an issue with the USB A cards. I have three of them, and two were working just fine before, so I doubt it’s an issue with faulty expansion cards. Tried rebooting, as well as checking for firmware updates with fwupdmgr – no dice.

$ sudo dmesg | tail
[ 1505.646711] usb 3-9: reset full-speed USB device number 3 using xhci_hcd
[ 1851.719163] lockdown_is_locked_down: 5 callbacks suppressed
[ 1851.719166] Lockdown: systemd-logind: hibernation is restricted; see man kernel_lockdown.7
[ 2147.702286] usb 3-9: reset full-speed USB device number 3 using xhci_hcd
[ 2664.526482] usb usb2-port1: attempt power cycle
[ 2672.982449] usb usb2-port1: unable to enumerate USB device

OS: Fedora 38
CPU: 11th Gen Intel(R) Core™ i5-1135G7 @ 2.40GHz
BIOS: 03.17
Kernel: 6.4.15-200.fc38.x86_64

Additional info (unsure if related): I can only get my USB C charging port to work correctly if the charging cable is in certain positions. This was a pre-existing issue, but including this on the off chance it’s relevant.

Have you tried a cold boot - power down the machine, unplug power, let it sit for a couple of minutes, then power back on?

If that does not work, you might try a mainboard reset - be careful when removing and reinserting the RTC battery, the holder is extremely fragile.


Hi @Tyler_Lanphear welcome to the community!

If you can first try what lbkNhubert suggested, then if it’s still showing the same symptoms, please open a support ticket linking to this thread.

How to safely remove the RTC battery, Step 5.

Cold boot seemed to do the trick! Thanks @lbkNhubert! Not sure why a regular reboot didn’t do the job, but I suppose hardware can be finicky like that.