[RESPONDED] A boot end up in a reboot, then it's ok


My laptop, a Framework Laptop 13 AMD Ryzen 7040 Series, with Manjaro & encrypted disk got this weird behavior : when I boot it (or reboot after working with it for some time), I enter my disk password, then the loading screen appears, get stuck. If I esc, I see the text dialog stating the services stopped & it ended up in a reboot state. So I reboot it, enter the disk password again, then it works normally, aka up to the login screen.

It’s not blocking or so much of a hassle, I reboot it only like twice a week. But I’d be curious to understand why. I’ve tried to read the logs from the journalctl -b-1, can’t really get it. Anyone can help me decipher it ?

Since the logs are over the limit of a forum post, here they are PrivateBin

Does it happen at every reboot?

I do remember that the Manjaro system (have a PIneBook pro) applies existing updates at boot and if it does, automatically reboots after applying these.
This also happens on ubuntu BTW.

Interesting lead indeed. Not sure about reboot every single time, but since I don’t reboot it often that could be it, and most lilely I only remember the stuck times. I see some stuff like

févr. 28 10:49:14 berget systemd[1]: Finished Updates device firmware whilst offline.

in the logs, but it ain’t clear if there was indeed an update to apply & subsequent reboot. Gonna reboot just now, as I had the case less than one hour ago, shouldn’t have anything waiting.

So, it isn’t systematic. A first reboot did go wrong, but not a couple of subsequent ones :thinking:

Firmware updates and regular updates cause a reboot on my systems.
So that’s what I’d check.

PS: I usually update the systems before shutting down.


Looking at the dmesg log, There are two things wrong:

  1. Entropy - it helps random numbers, and if there is not enough of it, the encryption stops working/blocks. The entropy gathering part is expecting a linux kernel <= 5.6 and you are booting with linux kernel 6.6.10. After a warm reboot, there is enough entropy so it can continue. So, look into fixing the entropy problem or don’t encrypt your disk.
    Fix by updating something called plymouth to a more up to date version that matches your kernel.
  2. There is a problem with the Wifi driver or firmware:
    févr. 28 10:49:15 berget kernel: mt7921e 0000:01:00.0: not ready 1023ms after FLR; waiting
    “mt7921e” is a chip on the wifi card.
    févr. 28 10:49:16 berget kernel: mt7921e 0000:01:00.0: not ready 2047ms after FLR; waiting
    So, upgrading to the latest firmware for the wifi card might help.
1 Like

So I solved 1. commenting out the kernel version requirement. I’m running latest haveged & up to date kernel so should be fine, entropy’s at 256, fine as far as I can tell.

# /usr/lib/systemd/system/haveged.service

The 2. is a bit trickier, Manjaro system settings doesn’t know the network controller

So lspci for more intel

❯ lspci -vv -s 01:00.0
01:00.0 Network controller: MEDIATEK Corp. MT7922 802.11ax PCI Express Wireless Network Adapter
	Subsystem: MEDIATEK Corp. MT7922 802.11ax PCI Express Wireless Network Adapter
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 116
	IOMMU group: 1
	Region 0: Memory at 8010900000 (64-bit, prefetchable) [size=1M]
	Region 2: Memory at 90b00000 (64-bit, non-prefetchable) [size=32K]
	Capabilities: <access denied>
	Kernel driver in use: mt7921e
	Kernel modules: mt7921e

Seems I’m in for quite some fun linux - mt7921e 0000:09:00.0: hardware init failed - Unix & Linux Stack Exchange

I’ll push further the search later, meeting time !

I’d try to first unload the kernel module rmmod mt7921e, and reload it (If it is not in use, it should work).
See if modinfo mt7921e provides some configuration options for that specific module. Can’t tell here as I don’t have any.

Not able to contribute much here as Manjaro has not been tested by us on Framework Laptop 13 AMD Ryzen 7040 Series. But I am following this thread.