[RESPONDED] CPU gets stuck at 0.2 GHz

How would you like it to be handled? Or less dramatic? Wonder if it’s something that Framework can provide options to in the BIOS.

Well, the issue is that it will be locked at an unusable 0.2GHz until you restart the computer, even if the CPU isn’t hot. I doubt that’s intended, and have never experienced this on any other device, ever. I’ve had choked laptops filled with dust that I haven’t cleaned in 5 years not exhibit these kinds of problems.

If anything, the CPU should do what’s expected, which is stop throttling once a reasonable temperature is reached.

CNR, my system handles overheats just fine.

I have a batch 1 device. Not sure if that makes any difference.

I wonder if this 0.2GHz thing is something at the hardware level on the processor itself…and it’s not even in the published typical speed range. i.e. The processor is taking over because all other throttling has not yield the desirable temperature decrease. The last straw at maintaining the system function without data loss…before full ungraceful power down.


If anything it’s an indirect indicator that the thermal solution…can run into an extremely dysfunctional state.

Nevermind, I still have this problem.
Sometimes the CPU throttling persists across restarts, at which point you have to disconnect the battery and RTC battery.
Seems the only sure way to prevent the CPU from permanently throttling itself is to prevent it from running at suicide clocks, i.e. use Window’s power management profiles to limit the max CPU utilization to 50% or something
The equivalent in Linux is cpupower-gui

Reach out to Framework support. They’ve been good with addressing thermal and performance issues for me.

Just to add my own experience to the thread — yesterday evening, I came back from dinner to find my laptop was off. I assumed this was due to an Ubuntu security update that kicked in after a confirmation dialog timed out. After starting the laptop back up, it was so slow as to be unusable.

I spent most of today re-installing Ubuntu to test the hypothesis that a buggy Ubuntu update had been rolled out, because I saw other people complaining about Ubuntu 22.04 being slow, and they weren’t using Framework laptops. After rolling back to Ubuntu 20.04 and seeing the same behavior, I started wondering whether there was a hardware problem. That brought me to this thread, and I verified that I was also seeing cores some running at 200 MHz, even after taking steps to put the OS in performance mode.

I then opened up the case and unscrewed the fan, blew a little here and there, re-seated the memory, and then closed the case again, and I’m seeing the kind of UI responsiveness I’ve seen in the past. Was the issue due to dust or a poorly seated memory chip or something else? I don’t know for sure. The laptop felt like a 1996 Java applet before, and now it feels like a laptop again.

I have a first-batch Framework laptop and have not yet installed the bios update people have mentioned.

I’m having a lot of trouble with my laptop, and I’m starting to get very frustrated with the ticket-support.
I spent way too much for a laptop that can’t use a calculator without locking up.

1 Like

I’ve been through that stage (for other reasons)…and gave up. Looking into the future.

I have a batch 2 laptop and have had this issue since release, I ended up buying a Macbook a couple of months ago because the laptop was totally unusable (its hot trash to be honest, I’m totally done with framework by this point, I just rebooted it to check the bios version and thats not visible in the bios so idk its still 0.2ghz after a reboot) whats the point of buying a laptop with 64gb RAM for work when the thing throttles to 0.2ghz and takes 30mins to recover?

I’ve relegated the device to running BOINC tasks in a spare room but have needed an x86 device recently for work and its still unusable as ever, I’ve tried everything, I even replaced the thermal paste and its just as much of a problem, as soon as it throttles the laptop becomes slow as molasses, gets stuck at 0.2ghz and takes 30mins to recover, I immediately have to unplug and plug the power to get it to be somewhat responsive again.

I can’t even give this laptop to family because I know they will have problems with it and I don’t feel comfortable selling it because its unusable, I’m lost as to what to do with it because its ewaste at this point.

1 Like

Did you reach out to Framework Support? I mean, it was under warranty…so…there’s that.

This is the part were we do our own QC (unfortunately)…and inform them on poorly behaving units…some of which should have not left the factories.

No I did not reach out to support, I followed this thread and there was no resolution to the issue from framework so I figured it was a design defect, this is the first I am reaching out to anyone about the issue - it takes a lot for me to reach out to support.

I’ve been having this issue running PopOS 22.04. I did a clean install of Ubuntu 20.04, and the problem persisted. After playing around a bit more, I’m beginning to see the pattern:

  • Whenever my laptop is running on battery, there is no issue
  • Whenever it’s plugged in through a USB-C expansion slot (I have two), it takes anywhere between 1-10 minutes for the laptop to throttle down to 200MHz and it remains “locked” there, and at the same time, the laptop appears to no longer be charging.
  • Whenever I plug the charger directly into the laptop (so instead of an expansion card), I have no issues either.

Since I have two USB-C expansion cards, I think it’s unlikely that it’s a hardware issue. Both expansion cards actually work fine when I hook my monitor up to them. I’m still guessing it’s somehow a driver issue, but I’m not sure.

Need details: CPU / mainboard generation / variant, and BIOS version.

Batch: #6 DIY
OS: Ubuntu 20.04.05 LTS
CPU: 11th Gen i5
BIOS: 3.10

Since I have a workaround for my particular issue, I’ve been lazy about systematically diagnosing the issue. I’ll make a bit more of an effort tomorrow to see if any particular port or expansion card seems to be the issue and report back here.

1 Like

I’ve just about had it with this laptop. It’s impossible to get any work done with these constant issues. I lost several hundreds of dollars just from the missed work this laptop caused me. And also the 1TB expansion card disconnects randomly - #104 by lbkNhubert . Oddly enough these started happening more frequently after the warranty expired. Framework doesn’t care about their users , they knew issues like these have been happening for over a while and still no permanent solution from them. This will be my only and last laptop I purchase from them.

I had the same issue on my 12th gen laptop, CPU clock on windows was stuck at 0.4 GHz, making the laptop borderline unusable. The fan was clear. Removing and reinserting the CMOS battery fixed the issue.

I hope Framework addresses this with the upcoming BIOS update.

Hi there, don’t know if anybody else tried this, but I may have found a workaround to keep this problem from happening:
The only caveats are that it keeps the CPU from using the full speed available, but it keeps the laptop stable, and if you update the BIOS it resets the settings, so make sure to keep an eye on that.
If you go into BIOS and set CPU to Max-Non Turbo Performance and Disable Intel SpeedStep, SpeedShift and Turbo Boost Max, then it should keep the problem from happening.
This is with a Intel 11 i5, 16gb RAM and Windows 11, but it also fixed the problem on a Intel 12 i5 as well.
Hope this helps somebody!

I’m having the same problem, stuck at .2 randomly, but it has become full-time now. Running 11 Gen with Win 11. Rebooting from cold overnight no longer fixes it. It even boots at this speed! I tried disabling SpeedStep, and that worked for a day. I thought it was fixed, but now it’s stuck for several days at .2. Computer becomes useless.

I would like to point out that this same issue is happening with other brands like Dell, HP, etc, that use this same i7 processor, so its not just Framework! No one seems to have a fix, so I can only conclude the problem is a bad Intel chip design or batch. Unfortunately, someone on here has indicated it is happening with the 12 gen as well. The other thing I notice is that the fan never comes on and when it is working normally the laptop becomes very hot. I replugged the fan but it made no diff. I will try replacing the paste and will try a new fan.

Framework really needs to make fixing this issue their number one priority, or I fear for their future (and ours, as customers).