[RESPONDED] Fedora 38 and extra screen via HDMI : Screen does not detect it's plugged in

I am using Fedora 38 and I have a bit of an issue with my old LG LCD screen.

On Fedora 37, I used to be able to just plug the VGA cable in the HDMI adapter and the adapter into the HDMI expansion card but it does not work anymore on Fedora 38. I assume it is the version change that caused it because I can’t think of any other change.

Whatever I do, the screen goes into “Power saving mode” because it does not seem to be able to detect it is plugged anymore.
I have tried turning it on after it’s plugged and vice versa, it doesn’t change anything
On the laptop side, the screen goes dark for half a second and I can see in the display setting that my extra screen is detected.

Do you have any idea on how to troubleshoot from there ?
Is there any way to send a signal to the hardware via the command line to wake it up ?

It’s not the best screen but I often need the extra screen room when I am working, it’s already installed on the wall and it does the job. I’d love not to have to throw it away just because of a software issue, plus I don’t really have the money.

I haven’t used my expansion card with F38 since adding a TB dock to the mix, so just thinking about troubleshooting on the hardware side:

Is the expansion card showing up on lsusb output?

Bus 003 Device 003: ID 32ac:0002 Framework HDMI Expansion Card

before/after plugging in the screen/it going dark?

Anything interesting on dmesg --follow output at the time you’re plugging it in?

Edit: tried different slots/sides of the laptop?

Ok, it just start working again, I have no idea why.

Thanks for the debugging tips !

What’s strange is that when I unplug the HDMI cable the screen turns off and the fans start getting quite loud for something like 40 seconds before it comes back

This is the output of dmesg --follow
When I plug the cable:

[35962.847925] Registered IR keymap rc-cec
[35962.847984] rc rc0: DP-3 as /devices/pci0000:00/0000:00:02.0/rc/rc0
[35962.848032] input: DP-3 as /devices/pci0000:00/0000:00:02.0/rc/rc0/input24

When I unplug:

[36041.819380] i915 0000:00:02.0: [drm] *ERROR* [ENCODER:266:DDI TC3/PHY TC3][DPRX] Failed to enable link training
[36055.388367] i915 0000:00:02.0: [drm] *ERROR* [ENCODER:266:DDI TC3/PHY TC3][DPRX] Failed to enable link training
[36070.916352] i915 0000:00:02.0: [drm] *ERROR* [ENCODER:266:DDI TC3/PHY TC3][DPRX] Failed to enable link training
[3[36075.602662] nemo-desktop[54248]: segfault at 1000 ip 00005610c7ca8465 sp 00007ffdb38d8ca0 error 4 in nemo-desktop[5610c7c20000+107000] likely on CPU 5 (core 8, socket 0)
[36075.602680] Code: bb 0f 1f 40 00 f3 0f 1e fa 55 48 89 e5 53 48 89 fb 48 83 ec 08 e8 1b f4 ff ff 48 85 db 74 2e 48 89 c6 48 8b 03 48 85 c0 74 05 <48> 39 30 74 0c 48 89 df e8 be 5c f8 ff 85 c0 74 12 48 8b 43 30 48

It seems like Cinnamon is the source of all trouble since there’s sefgault from nemo-destop (Sorry if I forgot to mention I was using the Cinnamon fedora spin)

Delighted that it’s working again. We do test on Ubuntu 22.04 GNOME and Fedora 38 GNOME desktops. Linux Mint is in your mileage may vary territory.

1 Like