[RESPONDED] Fedora version update issue - stuck in a login loop

11th gen laptop, factory bios, Fedora version 36–>37 (KDE) update problem.

Yes, 36–>37, not 38. As you can tell, not proactive with big updates. I fear them.

Didn’t wanna go through hassle of reinstalling applications, so (against better judgment of everyone on these forums) decided to update through dnf instead of clean installing Fedora. After all, it worked for 35–>36…

Made backup of files and got to updating per Redirect Notice

System restarted and now it won’t let me log in. If password is correct, screen flashes, brings up an on-screen keyboard, and returns to the log in screen (no error message displayed). If password is incorrect, says “incorrect password”. Does this for root and guest accounts. Persistent error on screen about “The current theme cannot be loaded”.

Not tech savvy, but tried:

Can’t roll back to Fedora 36.

btrfs navigating to Rescue gets me:

  1. can’t log in to emergency mode - root password incorrect.
  2. when press ctrl-D to continue, get:
    Starting default target
    [FAILED] Failed to mount boot-efi.mount - /boot/efi
    and a lot more failures.

UEFI exploration shows me:

  1. the SSD is attached
  2. EFI boot order is Fedora followed by ssd’s #

Searching for Fedora login loop problems online often point to full storage (not likely, drive had half a terabyte available pre-update) or dual boot problems (doesn’t apply…I hope).

Not knowledgeable enough to follow instructions on Fedora login loop - Unix & Linux Stack Exchange or figure out what to do in GRUB.

I’ve resigned myself to having to wipe the device and installing another OS. But if anyone can explain what the dickens happened or provide a solution, I’m ready to learn.

My two cents - we support Fedora 38 - and 37 as well. Anything older is community support.

You could try the whole chroot approach, but if you’re not tech savvy as you indicated, a clean install of Fedora 38, using our guide is the recommended approach to the easiest, smoothest experience.

1 Like

Get to login and do ctrl+alt+F2, that’ll put you into a tty. From there you can check journal logs or files, or just copy your data off in anticipation of nuking your install for a clean one.

Before that you could try startx from the tty, my login will fail if there’s an issue with my xorg configuration (eGPU not found correctly etc).

1 Like

I had a similar problem on my desktop machine. I had to fix my mesa installation. The problem was that I installed mesa-freeworld from rpmfusion which than broke the system upon a regular mesa update from fedora-system.
There is a rather heated discussion going on about this problem on some bug trackers.
But back to how I solved this problem:

  • boot the system
  • upon login switch to tty by pressing ctrl+alt+f2
  • login as root
  • ensure that all mesa packages are from fedora system and no updates are available
  • reboot

In my case the fedora update installed some mesa updates and everything was back to normal. Maybe this can give you a tip into the right direction.


Do you have a link? I love watching how badly those are handled.

Thanks for replies and tips. Could never get to tty (ctrl+alt+f2 and any other button combination got me jack all on the login screen) but was able to use a live image of Fedora 38 to rescue a few final files before doing a clean install.

@S.H thanks for posing a possible cause for the breakage! Seems reasonable, I got mesa off rpmfusion to get GOG games functioning…

1 Like

Let us know if @S.H’s solution solved your issue and we’ll mark this as solved. Thanks