[RESPONDED] Framework 16 Docking Station for Linux

Hi there, I’ve read through the USB-C/Thunderbolt Dock Megathread and I have now tried two docks, neither of which have worked properly:

  • Satechi - Thunderbolt 4 Slim Hub 5-in-1 - USB-C 60W, Single 8k or Dual 4K Display, 4 Thunderbolt 4 Ports, USB 3.2 Gen2 - Space Gray

The above didn’t work as it’s only TB4 as opposed to USB4, so I returned it and purchased one of these:

  • Plugable Thunderbolt 4 Dock for 4K Dual Monitors or Single 8K, 100W Laptop Charging

Thinking this one would work with USB4 as the box literally says “Thunderbolt 4 & USB4 Dual HDMI Display Docking Station with 96W charging”

Does anyone have a suggestion of a good USB4 dock which supports 2x1080 monitors via HDMI or USB-C, along with Ethernet?

I’m running the latest KDE Neon with the integrated GPU and a 7840HS.

Thanks!

I have this docking station for my Framework 13 and plan to use it on my Framework 16. It’s not Thunderbolt, but it is a very good single cable solution for charging (85w), 4K monitor, and SD card reader.

https://www.amazon.com/Anker-Docking-PowerExpand-Charging-Ethernet/dp/B088F7SY6S/ref=mp_s_a_1_3?crid=J4R0SNJHLWFZ&dib=eyJ2IjoiMSJ9.5yhcDEZKxfubgYe0TvubBl9gL5cQk9admA7wvqV35oWeQbi7JbZkpx86MdK0dpsi0hzjQEJSWc-zdAorT_i4TGickPlEa92nocPpa0JCMBH1irjyqYtSf5FSrxyJasHD0ClMTFqOhafY35cT4dzMWfoY_KoFVLIGC6RxiUJsFBYJBpN_-TilWH0Fq-ZgfxfFKfWIJOX7H2A7x7g3V2zIfg.Knirqf9WPVUkEj3yS2kVLscSDkJ_zqCigLRzE2xBfaE&dib_tag=se&keywords=anker+docking+station&qid=1712026548&sprefix=anker+dock%2Caps%2C148&sr=8-3

1 Like

Thanks for the suggestion, @henrytr! Are you only using a single 4k monitor as opposed to dual monitors?

Yes. I have a single 4K 27" monitor that I have mounted directly above the laptop in a “stacked” configuration. I think the Anker docking station can push two monitors, but I’m not certain.

Nothing too add here as we do not officially test against any specific docks. As a general rule, USB functionality should be fine with most docks. Video out is best with our expansion cards. Docks can be pretty hit and miss.

Well, using the Dell WD19TB dock with KDE Neon.
Everything works, except at boot. The screen won’t come up/show up.
I suspect a bug with the plasma startup which gets stuck in waiting state if booting with dock connected. Unplug and re-plug and it works.
it seems the Dell dock provides max 60W of power though, even if it has the 140W power-brick. But that seems to be a Dell thing.

When gaming, I switch to the Framework 180W brick :}

1 Like