[RESPONDED] Headphone jack intermittent noise?

I did some additional debugging with PowerTOP tunables, and have isolated the static and crackle I experience to occurring when power management is enabled for “PCI Device Intel Corporation Tiger Lake-LP Management Engine Interface”. This device has the driver mei_me, and is in TLP’s default RUNTIME_PM_DRIVER_DENYLIST, however, it seems that that setting doesn’t matter if the Kernel sets the power control for the device to auto.

To resolve, I added a custom udev rule to force disable PCIe runtime power management for that device (using this doc as a reference; I don’t use Arch, but its wiki is great):

SUBSYSTEM=="pci", ATTR{vendor}=="0x8086", ATTR{device}=="0xa0e0", ATTR{power/control}="on"

Alternatively, one could set RUNTIME_PM_DISABLE in TLP, but that requires specifying the PCIe device path rather than ID, and the latter is typically more stable (or at least portable).

After a reboot to load the new udev rules, the ME device is successfully excluded from power management, and so is always on even on battery, and, albeit just with some short testing, I no longer have any crackle.

Note of course that it’s possible that the cause of my crackle is different than others, as mine seemed more reliable to reproduce and not tied to a channel as it was for others. But hopefully this helps someone.

5 Likes

I have persistent subtle crackling too, and unfortunately this didn’t quite do it. But I have a feeling it is still power management related. I’m using power-profiles-daemon and the crackling is much less noticeable when running in a higher power state (Balanced/Performance) than when in Power Saver mode.

1 Like

I am experiencing a similar issue on my laptop running Ubuntu 21.10. I have the newer IDT 92HD95 chip. There are two issues:

  • Whenever the sound card is started, it produces a “click” sound. I’ve had this issue before on other laptops, and the solution has always been to disable snd_hda_intel.power_save so that the card is only started once on boot.
  • More importantly, there is a constant, quiet white noise played from the headphone jack at all times when the card is active.

A few things I’ve tried:

  • Upgrading kernels. Both 5.13 and 5.15.4 have this issue.
  • Fedora 35, which uses Pipewire instead of PulseAudio, also has this issue.
  • Setting snd_hda_intel.power_save=0 as a kernel param. In some ways, this makes it worse, since the white noise is only produced when the card is active, and this makes sure that the card is active all the time.
  • Different headphones. I’ve tried 2 different sets of headphones, with no difference.
  • Power profiles, peripherals, or whether I’m on battery or AC make no difference.
  • Whether something is actually playing makes no difference. It’s easier to hear the white noise without something playing, but I can still hear it while listening to music.
  • Messing around with hdajackretask didn’t seem to do anything, although I don’t know what I’m doing.
  • TLP stuff doesn’t apply, I don’t have TLP running right now.

I’m kinda at a loss for how to proceed from here. Is this potentially a hardware issue?

4 Likes

Chiming in to say I am also having the issue on my Oct Batch 1165G7 running Windows 10 Professional.

I don’t have much to add regarding troubleshooting as I have no idea where to even begin with this kind of issue.

1 Like

I’ve not much to add, either, some sound issue on November batch DIY i5, Fedora 35 KDE (on both Wayland and Xorg). Kind of similar to what @ImaxinarDM mentioned.

Whenever I’m going from silence to audio playing (even system sounds or notifications), there’s a sharp beep or crackle. Only happens if something is plugged in the audio jack. Laptop speakers themselves and anything attached via HDMI don’t produce this sound.

1 Like

@popcornbushwhacker That problem has a mitigation. You can try running
echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save
and it should stop clicking every time. If it works, you can set snd_hda_intel.power_save=0 as a kernel boot param to make it permanent.

1 Like

@Passerine this hasnt worked for me unfortunately, i still get noise

2 Likes

@Passerine Thanks for the quick response, always wows me when linux experts get can suggest a solution just like that.

But, like @endermanwithinternet, it doesn’t seem to get rid of the noise.

1 Like

I am on popos 21.04 and encountering very similar or the same issue when using the 3.5mm audio.

Static/crackling in the left channel, primarily when audio contains voices. Especially so if the voices are in the right channel. Opening the sound settings and testing the right channel (which plays a voice saying ‘front right’) causes a very noticeable amount of static in the left channel.

I’ve tried some of the power saving mode suggestions mentioned in this thread and so far no luck. It’s pretty consistent except with volume. Lowering my volume to about 25% or lower it stops occurring or may just be too low for me to notice.

I tried the udev rule, setting performance to high, and using tcp. Nothing works so far. Given so many people have a similar issue I don’t think it’s just a loose plug but maybe I’ll open up the laptop and try and reseat the module? Out of ideas otherwise.

1 Like

Pop_Os 21.10 beta, same issue. Tried Fedora 35 as well, but same weird static.

Not a major issue, I got a USB headphone, but if I knew before (Which I could’ve by looking more on the forum), I’d have gotten an extra USB-C module

1 Like

Was suffering popping issues. Was using my M1 MacBook Air’s charger. I switched it with the Framework charger and the popping stopped!

2 Likes

On my new Framework everything works great but when listening through my earbuds it sounds like background static.

Is there a way to fix this or is meant to be, if so I got some problems.

Thank you

1 Like

Same when my headphone plugged in. I read other have the same issue

1 Like

I am also getting the white noise using Ubuntu 20.04, batch 5, without TLP.

1 Like

I don’t get any constant noise, but I do get an intermittent popping or chirping sound whenever the Tempo chip turns on and off. It happens in both Windows 11 and Gentoo Linux. Windows 11 seems to hold the chip constantly on, as I only hear it when logging in and out. Gentoo by default tries to save power by turning the chip on and off, but a fix is to open Kmail, since it has a bug where it opens a bunch of accessibility related audio streams and never closes them, so the chip never turns off.

2 Likes

I’m seeing the same persistent static issue coming from the headphone jack with Ubuntu 20.04 on Batch 6 (December 2021). The static stops whenever the sound driver enters powersave mode and the static starts again as soon as I try to play any audio. No other issues with the laptop. For my situation I can be sure it’s not caused by any electromagnetic interference external to the laptop case (i.e. no interference from a power cord or anything like that), but maybe there is interference within.

It requires a mildly high sensitivity set of headphones to hear it. Using airplane-quality headphones makes everything really quiet, including the static, and allows increasing the volume a lot, enough to overpower the static. But with high quality headphones, the volume must always be kept fairly low, and the static is unbearable.

2 Likes

I’m also experiencing this both on battery and when charging. Every time audio plays there’s a high pitched chirp, then static until power saving turns it off. It’s really annoying when receiving frequent message notifications. Turning power saving off makes the chirps only happen at startup but the static is still very distracting.

2 Likes

Hello, everyone,

Since I see quite a few are facing similar issues, we ask that you please create a support ticket here: Framework | Support so we can track this issue and do what we can to assist you! If you have tried any troubleshooting yourself, please do let us know so we can gather as much information as possible!

Thank you, everyone! :orange_heart:

2 Likes

Batch 6 - received last week - bios 3.07
I am also having the issue described by others here. With my headphones plugged into the laptops 3.5mm jack, an electronic beep when powersaving switches the audio interface on and off, and I get a constant noise floor when the interface is on. My headphones are quite sensitive (32 ohm) so it’s especially annoying.
I’m on firmware 3.06, os: manjaro - kernel 5.15.7, no powersaving software installed (tlp, powersave-daemon, etc explicitly uninstalled)

I opened a support ticket so we’ll see where that goes!

1 Like

Just a quick blurp, but I have not had any noise issues with the headphone jack since upgrading to Windows 11 and using BIOS 3.06 (now 3.07). I’m back on Windows 10, but before I did that I was on Ubuntu 20.04 using Sway and I had no issue with the audio jack.

I have a gen 1 mainboard using the realtek audio so that might be a factor. I believe my wife’s Framework is from batch 5, and she is using the other audio chip used on later gen mainboards. I haven’t noticed any audio noise on that audio jack either.

Not super conclusive I know, but hopefully that helps nonetheless.

2 Likes