[RESPONDED] How to enable S3 Sleep on AMD Framework?

Hi all,

I know that S3 sleep is not ‘officially’ supported on the intel machines, but seems to work.

Is the same true for the AMD Framework 13? I can’t find anything in the bios to enable, on prior ThinkPads it’s been a setting like ‘Enable Legacy Linux Suspend’.

Hoping someone has the answer!


User sleep then hibernate if you want similar behaviour

Yeah that’s what I’m doing right now, but the resume time is much longer for hibernate. Seems like there’s no way to enable S3?

Even on Thinkpads that are Rembrandt or later S3 has been dropped.
It was only an option with Cezanne and earlier.

If you have power consumption issues over s2idle please check with scripts/amd_s2idle.py · master · drm / amd · GitLab

Also be sure that you have the cards all in the slots suggested by Framework.


Marking this ticket as replied, thanks Mario. :slight_smile: