[RESPONDED] iwlwifi problem on Fedora 38


I use Fedora 38 Workstation on a Framework Laptop 12th Generation, and I keep having issues that seem to be related to iwlwifi and kworker. Randomly, the wifi stops working, everything becomes slow, application crashes, flatpaks do not launch. When I try to restart NetworkManager “sudo systemctl restart NetworkManager”, it just hangs. I tried to reinstall the firmware “sudo dnf reinstall linux-firmware”, but it keeps happenning. The wifi card is an Intel AX210. It is very frustrating.

wifi kernel error: iwlwifi error - Pastebin.com

Here is the entire journalctl log

lpsci -k: lpsci -k - Pastebin.com


dmesg | grep firmware: grep firmware - Pastebin.com
dmesg | grep iwlwifi: grep iwlwifi - Pastebin.com

Out of curiosity, was anything custom done with firmware outside of standard update channels? Does this work reliably on earlier kernels (Fedora keeps a few of the previous ones installed by default).

No I did not do anything with the firmware. It also happened with Kernel 6.2.9.

@Loell_Framework if you’re 12th gen has a similar Intel AX210 wifi card, try installing Fedora 38 and see if you’re able to replicate this on the latest kernel provided by Fedora updates.

Update: Same issue with Kernel 6.4.4

After another episode, the laptop just does not wake up. The screen showed lots of pixels of different colors

(sorry for the quality)
and the laptop just does not wake up at all (the backlight of the keyboard only is on) but the screen remains black and the LED shows up some color code

After trying to remove one barrett of RAM and then the other it does wake up after removing the second…
It does not wake up after placing the faulty RAM back up! I took the RAM from Framework so I guess I should contact support

Update: It seems to depend less on the RAM barrett but more on which slots have RAM in…

Sometimes it does wake up sometimes not i tried to boot on a Fedora 37 live installation but it does not want to and spits kernel panic errors

Definitely sounds like RAM issues, please do open a support ticket and provide a link to this thread as it will add context that this does appear to be board/RAM related based on your troubleshooting.

By removing an SSD to try to trigger things and change conditions, I managed to boot with 2 sticks on a memtest live USB, and it does look like a mainboard failure since it detected 4047 errors in 2:30 minutes. It does not show any error when I test each stick on the right slot. Seems like something is bad on the slot or the connection to this slot or something.
I contacted support.

I am in favor of this going into a support ticket for sure.

Update: After going back and forth with Support, I will be sent a replacement mainboard.

1 Like

Do update us how your replacement mainboard goes. :slight_smile:

with only one stick of RAM on Slot 0, and the old mainboard (i still did not receive the new one), there are serious visual glitches that appear regurarly, and a persistent black band at the left. i have not dropped it or anything. any way to know if it is also mainboard related or screen related? What worries me is that the glitches seem to appear more when moving the screen

it also does the same in the bios

Please open a support ticket for assistance with this. This appears to be hardware centric, but we can assist you further in a ticket as we need to run through some additional troubleshooting with you.

Hello, I use Fedora 38 but it is unlikely to be linked to it. I’ve already got issues with my mainboard since it only boots with 1 stick of RAM, so support will send me a new mainboard. Thing is, I pressed a thumb on the bottom of the frame and since then, a black band appears at the left, and it glitches. There is no visible crack or anything. I’ve got confused if it was caused by the mainboard issue, but it seems unlikely, since it works fine with an external monitor and if it was the iGPU I guess I would see the same issues also on the external monitor. It does the same everywhere, in the bios, in the login screen, in the OS… I will try to see if it changes when I receive the new mainboard, but I have the feeling it must be the display since it appeared when I touched it.

I already tried reseating the connector, it does nothing

Doesn’t look like the screen is broken, imo. But could be the cable or one of the connectors. If mainboard replacement doesn’t resolve it, maybe the cable could be replaced.

I saw something like this when I dropped mine and the cable came loose, behind the screen, but reseating worked in my case.

1 Like