[SOLVED] Wifi issues on Fedora 37

I received my Framework about two weeks ago and have been having wifi issues on and off pretty much since the beginning. I’m running Fedora 37 pretty much always up to date, on a DIY 1240P with the default 210AX card.

I’ve run journalctl a few times and see a red wall of fedora-framework kernel: iwlwifi 0000:a6:00.0: errors whenever it happens, but that’s where my tech saviness ends I’m afraid. I found a few forum threads with similar issues, but they seem to be from 2021.

Here are the logs of two different incidents:

1 Like

The first error message in your logs:

iwlwifi 0000:a6:00.0: Microcode SW error detected. Restarting 0x0.

indicates that the actual WiFi device crashed. That could be due to a number of different reasons ranging from:

  • Firmware bug
  • Hardware bug
  • Your particular card being defective

There could be things about your setup that trigger the problem ranging from:

  • Your particular router
    • It may be sending a malformed/out of spec packet that the card is not handling properly
  • Use of Bluetooth & WiFi simultaneously
    • this may be triggering a problem
  • Placement of other devices
    • I’ve seen placing a webcam on my old laptop lid cause wifi crashes like this!

It’s first worth applying all updates and performing a full power off to wipe any memory state in the wireless card. It may then be worth enabling the Fedora-testing repository and upgrade to the latest kernel & linux-firmware packages.

There is a newer WiFi firmware already installed, but the driver is set to request that older version. Making it use the newer version is not a simple procedure unfortunately.

Intel has a lot more resources at en:users:drivers:iwlwifi [Linux Wireless]

It’s also worth check the Fedora bugzilla and seeing if anything there matches the issue you’re encountering: https://bugzilla.redhat.com/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&columnlist=product%2Ccomponent%2Cassigned_to%2Cstatus%2Csummary%2Clast_change_time%2Cseverity%2Cpriority&component=kernel&order=status%2C%20priority%2C%20assigned_to%2C%20id%2C%20&product=Fedora&query_format=advanced&short_desc=iwlwifi&short_desc_type=allwordssubstr


So, I’ve experimented and think I can rule out a few things:

I’ve a) shut off the device for a few hours and removed the wifi card, so cache should be cleared. I’ve b) used the device in different wifi networks at home and at uni. I’ve c) deactivated Bluetooth for a while.

The issue still persists.

I’ll try enabling Fedora testing next. Depending on the results and whatever I may dig up on Bugzilla the next step would be contacting Framework support I guess.

I use my provided wireless card in Fedora 37 (using it right now). I agree with @egalanos, this looks to be hardware or router.

If it was me, I’d test this by trying to connect to another network. If you’re seeing similar errors still (on a completely different network), then it is likely a bad card.

Of course you could also verify it is fully seated, and the antennas are connected.

1 Like

Excellent point! I’ve been hit with this myself before – happens. :slight_smile:

1 Like

So, the good news is that wifi seems to be stable now. The bad is that I have no idea why.

Since my last post I’ve a) installed the newest kernel 6.0.13 from Fedora Testing, b) updated the OS of my router (two point releases that weren’t done automatically for some reason) and c) reseated my card for a second time and wiggled the antennas a bit. One of the three seems to have solved the problem.

Over Christmas I’ll be visiting my family and keep an eye on further errors while in their network, but I haven’t had iwlwifi errors over the last three days, so I’m carefully optimistic.

Am I supposed to mark the thread as “closed”, and if yes how?

I went through your logs and am reasonably confident our issues are different. You might be better served opening up a new thread or a support ticket.

As to how to learn how to deal with bugs like this, step one would be going through journalctl and dmesg, identifying whichever service is likely causing the problem and reading up on what they’re supposed to do. Understanding what to ask will help you find solutions faster and describing your issue more accurately will allow others to better help you.

1 Like

Completely agree, excellent advice.

Two things to make a physical note of before an update in case this happens again:

NetworkManager -V

uname -r

gnome-control-center --version

If an update, updates one or both of these, you then know what to look for in the logs.

Most common culprits are kernel and/or NetworkManager updates.