[SOLVED] Could this kernel panic be Framework-related?

Never run into a kernel panic in years of running Linux, but this happened a day after I received my Framework and transplanted my drive into it. I believe I ran pacman -Syu and it updated the kernel and some KDE apps. I’m currently investigating further myself, but I thought I’d post it here in case it was related to the laptop in some way (perhaps the bios?) and anyone else had run into it or had insight into what I could do on the off chance that this is hardware related and my search for answers elsewhere comes up dry. Any help or advice would be greatly appreciated.

Sorry if that was at all nonsensical or rambly, I, like my kernel, am panicking.

That looks like a corrupt file on the root filesystem. You may want to boot rescue media and run fsck!

Unless there’s an NVMe incompatibility, this is unlikely to be a Framework-specific issue.

1 Like


I just found out that my snapshots stopped being taken almost three months ago without me realizing :expressionless:

This seems most likely, try booting into a live environment then chroot into your linux installation and try reinstalling the util-linux-libs package as this is the package that provides usr/lib/libmount.so.1

Solved… sorta.
BTRFS superblock was corrupted. Had files backed up, so decided to reinstall rather than try to fix an unrecognizable filesystem.

Thanks for all the help.