[RESPONDED] "No NVIDIA kernel modules loaded, using nouveau", DE bugs, and other fun issues

  • Linux
  • Fedora 40 (MATE spin)?
  • 12th Generation


Hello, I have 3 issues with Fedora that I can’t seem to find anywhere.

  1. Is there an intuitive and foolproof way to install Nvidia drivers on Fedora MATE? I tried installing them, but the system doesnt recognize them and falls back to iGPU. On boot, the screen displays “No NVIDIA kernel modules loaded, falling back to nouveau instead.” I tried all the ‘solutions’ I could find, but to no avail.

  2. For whatever reason, the MATE environment failed after changing some custom settings. I can only get my panels back after typing “mate-panel reset” into the console. Very annoying, I have no clue why it suddenly decided to become fickle after customizing it some.

  3. Is there an easy and intuitive way to sandbox applications? All my friends use Spyware-cord, and I want to be able to talk to them but it seems like no one in the past several years has created a foolproof sandboxing/jail GUI.

My DE is glitching out a ton, with apparent z-fighting with a new background image? Again, sorry for my ineptitude.

Hi @Jonjon ,

Can you first check if you’re having same symptoms with vanilla Fedora 40 live? or Fedora 39 Live?

Just to make sure if your video is properly detected. thanks. :slight_smile:

Of course.

I am, however, starting to suspect that eGPUs with laptops are nearly completely broken and an extreme edge case. I think you guys should give a forewarning letting people know how painful trying to get it to work is (not implying any of you did something wrong.)

Both Fedora 39 & 40 live would freeze the moment I connect the eGPU, no matter if I left it in from boot or plugged it in after booting into the usb.

Any updates?

Hey @Jonjon ,

can you check if card is visible on system at all?

lspci | grep -e VGA


lspci | grep -e 3D

VGA compatible controller: NVIDIA Corporation GA106 [GeForce RTX 3060 Lite Hash Rate] (rev a1)

Running "lspci | grep -e 3D returns nothing.

do check what nvidia packages are installed
dnf list installed *nvidia*

also check if no nvidia modules are loaded

lsmod | grep nvidia

Installed Packages
akmod-nvidia.x86_64                   3:550.78-1.fc40 @rpmfusion-nonfree-updates
                                      3:550.78-1.fc40 @@commandline             
                                      3:550.78-1.fc40 @@commandline             
libva-nvidia-driver.x86_64            0.0.11-3.fc40   @fedora                   
nvidia-gpu-firmware.noarch            20240410-1.fc40 @updates                  
nvidia-modprobe.x86_64                3:550.78-1.fc40 @rpmfusion-nonfree-updates
nvidia-persistenced.x86_64            3:550.78-1.fc40 @rpmfusion-nonfree-updates
nvidia-settings.x86_64                3:550.78-1.fc40 @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64            3:550.78-1.fc40 @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda.x86_64       3:550.78-1.fc40 @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.i686    3:550.78-1.fc40 @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64  3:550.78-1.fc40 @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64    3:550.78-1.fc40 @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.i686         3:550.78-1.fc40 @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64       3:550.78-1.fc40 @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-power.x86_64      3:550.78-1.fc40 @rpmfusion-nonfree-updates

and, respectably, the second returns nothing.

Wait, did my nvidia driver uninstall itself? I swear, I am not screwing around with you at all.

What do I need to do to fix this?