[RESPONDED]Pop!_OS Anyone has tried it on the FW13?

How is the compatibility of Pop!_OS on the Framework laptop?

I knew the os isn’t officially supported, but wondered if anyone made it fully functional on the Framewrok?

Genuinely curious to know as well, although for good user experience we tend to encourage FW13 users to use officially supported ones ( Ubuntu and Fedora )

As of 2 months ago, PopOS was broken. There is some significant issue that causes unpredictable behaviour(freezes, hangs, etc). I’ve since switched to fedora and am pretty happy with the out-of-the-box experience sans some minor qol issues.

The main thing i miss about Pop is their tiling manager and some occassional settings exposed by PopOs that fedora doesn’t. On the other hand, ootb power management on Fedora is top notch (for an intel system)

1 Like

It is still running fine on my 11th Gen i7-1165G7. I keep up with updates in pop shop.
With pop-os 21.x I had to install wifi drivers but if I recall correctly, installing 22.04 when that came out, everything worked out of the box.
I have not used the finger-print reader though.
No dual boot or anything complicated other than I converted to btrfs immediately after installation.
New kernels have always booted fine. I’m at linux 6.4.6 as of a couple days ago.

I mostly followed this guide:

1 Like

We encourage folks to test and try different distros, however, if you experience and issue with it, you will be asked to troubleshoot using Ubuntu 22.04 or Fedora 38 to rule out hardware or a bad configuration with a given distro installation. Thanks

Fair enough, I have used both Ubuntu and Fedora, but only personal preference to stick with Pop OS.

Same thought, the tiling really enhances my work flow

1 Like

Pop shell which does the tiling is a gnome extension and can be added to gnome with other distros. Several even have it as an available package.
See GitHub - pop-os/shell: Pop!_OS Shell .


Thank you @Spence not sure why it never occurred to me. I always assumed you’d have to change to a new wm to have this. I have now installed Pop Shell and it works so far :pray: