[RESPONDED] Possible Causes for Slow Wi-Fi Performance: Troubleshooting and Seeking Solutions

Hello everyone,

I recently received a framework laptop with i5-11th gen as a gift from my brother that was purchased in Germany. Initially, I was excited about it, but my happiness was short-lived when I noticed that the Wi-Fi performance was extremely slow. In fact, my half a decade old phone and laptop performs 10 times better than my FW in the same room. I get 2-3MB speed regardless of my distance to the router, when other devices get up to 50mb effortlessly.

I installed Ubuntu to see if it was an issue with the Windows 10 operating system, but the problem persisted. I even tried using my old MediaTek Wi-Fi card, which didn’t solve the issue. I also tried replacing the antenna cables, but that didn’t work either.

The laptop has an Intel AX210 Wi-Fi card, which interestingly works perfectly when used on another laptop. At this point, I am unsure what is causing the problem. I have ruled out the Wi-Fi card, the operating system, and the antenna cables.

Could it be a faulty motherboard that is causing the issue?

I would appreciate any insights or advice on how to troubleshoot and resolve this problem. Thank you all for your time and support.


Did you try the solution suggested in Very slow WiFi on a new Framework with Linux Mint - #6 by Matt_Hartley?

Did you install the Windows drivers from Framework?

I doubt that the motherboard is faulty.

I have tried both drivers for Windows, first original ones come with the driver bundle, then latest drivers. Did not solve the issue.

What’s your router/network setup?

Which bands does the laptop connect to with the router?

Also, when using Windows or Linux, what do the event/kernel-logs say? Anything related to wifi?

1 Like

The router is 2.4ghz only.
Link speed is 130MBS.

I have tried changing the router settings, restarting it, trying several channels, nothing has changed.

Also installed drivers from Intel Driver Support.

Don’t know much about Linux, but I have the USB with me, are there any commands I can run that gives the results might be helpful to solve the issue?

For Windows, check the Event Viewer.
For Linux, dmesg -w in the console and/or journactl.

Are both connections from and to the laptop slow? If you transfer a file to it via network, is it slow or fast?

I will try those once I get home.
Not only the speed, but also the signaling is weak too.

It shows 1-2 lines signal on windows, and all other devices shows 4-5. Even with other antenna and wifi card, and even on linux it’s still a terrible signaling.

Did you double-check that the antennas are securely attached to the wifi module in the computer? Have a look on the Framework support site on how to install/replace the wifi module for info on how to get at the unit and how it’s supposed to connect to the antennas.

Yes, followed the instructions. I have installed antennas many times, I can confirm they are properly seated. I also tried different antennas, the connection quality was identical.

99% of the time, this has to do with how the card is receiving your wifi signal. All of that said:

  • Double check your card connections themselves.
  • On Ubuntu or Fedora, run this - just copy and paste the code block into a terminal, then copy and paste the results back here.
interface=$(nmcli -t -f active,device d wifi list | grep '^yes' | cut -d':' -f2)
echo -e "\n        \033[1;33mInterface: $interface\033[0m"
signal_strength=$(iw dev $interface link | awk '/signal/ {print $2}')
echo -e "        \033[1;33mSignal strength: $signal_strength\033[0m"
signal_quality=$(nmcli d wifi list ifname $interface | grep '*' | awk '{print $8}')
echo -e "        \033[1;33mSignal quality: $signal_quality\033[0m"
signal_bars=$(nmcli -t -f active,bars d wifi list | grep '^yes' | awk -F: '{print $2}')
echo -e "        \033[1;33mSignal bars: $signal_bars\033[0m"
speed=$(nmcli -t -f IN-USE,RATE dev wifi list | grep '*' | awk -F: '{print $2}')
echo -e "        \033[1;33mWi-Fi Speed: $speed\033[0m"

If connecting to mesh, it will vary and you may see signal going from 100 to normal as it self-adjusts.

But do post the output here.

Mine for example is:

    Interface: wlo1
    Signal strength: -45
    Signal quality: 75
    Signal bars: ▂▄▆_
    Wi-Fi Speed: 270 Mbit/s

This isn’t permement, but worth trying for troubleshooting - we can make:

sudo modprobe -r iwlwifi

sudo modprobe iwlwifi 11n_disable=8

See if things improve with speed here.

If not, try again this time using 1 instead of 8.

You also indicated getting this from Germany. Might be worth checking the following in a terminal as well:

sudo iw reg get

Then share that output as well.