Wifi getting moderately slow speeds


My frame.work is generally fantastic. However, I have an issue with wifi speed. While it is fast “enough”, it is much slower than another system I have, by a factor of 5-6. I tried the following steps to troubleshoot this:

  • Did speed tests in both Linux (kernel 5.16.16) and Windows, on both my “old” system (a Thinkpad) and the Frame.work.
  • Swapped the wifi cards between the systems, and verified that the ax210 that came with the frame.work was able to get the 5-6 faster speeds.
  • Verified these faster speeds in both Linux in Windows.
  • Verfiied the slower speed with the old known-fast wifi card on my Frame.work (in both Linux and Windows)
  • Replaced the wifi cards back to the original positions, same thing with speeds.

This is after ensuring I’m running the latest drivers offered by Frame.work, and also checking that my iwlwifi firmware is up to date. I was about to conclude that the Frame.work just has a chassis that interferes with the signal, but then I saw some posts of people who have really fast speeds.

The only thing left I can think of is a bad antenna. Any other suggestions?

Thanks in advance!


Is there a way I can get a replacement wifi antenna? Not the card (the AX210 seems to work fine), but the antenna itself.

I live in Germany, so maybe the infrastructure isn’t set up yet to handle requests like this. Also, even though I’ve had this system for less than a month, I am willing to pay for it to help support the company. I’m also patient, as wifi works ok, just not super fast.

I believe I’m experiencing the same type of wifi slowdown as you.

You have not posted in awhile. Were you able to resolve the issue?

Is there a solution for this problem? Have the same prob. Max 2mbits but the cellphone reaches 50mbits at the same position.

I found a solution. I gave my 11th gen to a relative and bought the 12th gen.

WiFi now running at 100%, lol

Had the same issue.

Solved by

iw dev
find your wlan device number in my case “wlp170s0” then
iw dev yourwlanadapterhere set power_save off