[RESPONDED] The differences between the Thunderbolt connections

I have noticed a strange problem over the last few days and would like to try to find a solution with the community and support. It concerns my Frramework 13 with Intel CPU of the 13th generation.

Problem description

I have a Dell notebook with two Thunderbolt-capable USB-C ports and my Framework. Windows 11 runs on the Dell and ArchLinux with the latest update on my new framework. I would like to use the network functions of Thunderbolt. This allows you to set up a very fast P2P network. I bought this cable to connect the two notebooks:


If I use the Thunderbolt port on the back right of the Framework to connect the two devices, I can’t establish a network connection. I only see the following messages in the log as a loop:

[  401.204388] thunderbolt 0-0:1.1: new retimer found, vendor=xxxxx device=xxxxx
[  402.267020] thunderbolt 0-0:1.1: retimer disconnected
[  403.899729] thunderbolt 0-0:1.1: new retimer found, vendor=xxxxx device=xxxxx
[  404.951485] thunderbolt 0-0:1.1: retimer disconnected

However, if I use the connection at the back left, I also get the message briefly, but after a short time I have a network connection between the two devices.

Attempted solutions

Since I have problems with the HDMI expansion card and the standby, I have removed it from the device. Unfortunately, no change.

I also swapped my two USB-C expansion units, but this did not move the problem. Therefore, I do not assume that it is due to the expansion cards that lead USB-C to the outside.

Wish to the readers

If you are a manufacturer, I would be pleased to receive suggestions for solutions. If not, of couse too.

I would like the community to check whether this problem also exists in your case or whether my device is simply broken.

Hi @DO3EET , welcome to the community.

Seeing that your using arch, can you try fedora 39 Live or Ubuntu 22.04 Live?
Try if thunderbolt P2P network is improved in these environment?

Hi @Loell_Framework
Thank you very much for your quick feedback
Unfortunately, I was able to reproduce the problem on both Live Linux distributions.

What I have done

I downloaded both ISO files for Fedora and Ubuntu from the respective manufacturer websites. I then created a USB stick with Ventoy and booted from it.
During the first boot, I stored the required secure boot key via Ventoy and tested Fedora first. Here I was able to reproduce the problem with the connection 1:1. The connection at the back right does not work, but at the back left it works without problems. I never disconnected the cable from the Dell.
I then booted Ubuntu and had the same problem here too.

what I will do now that I have sent the message

To restore a certain level of protection, I will delete the Ventoy key from the Secureboot again.


The problem can be reproduced in the live distributions of Ubuntu and Fedora on my Framework 13 notebook.

It seems to be a problem with the cable length. I have just used a longer cable and it works on both sides. But there doesn’t seem to be any problems with the short cable when using an SSD. I have also rotated the cable several times to rule out missing pin assignments. It also does not explain why the short cable works on the left side and not on the other side.

any news from your side?

Hi all
I still waiting for an update from Framework… @Loell_Framework

In my experience, the right-side Thunderbolt ports didn’t work because my power supply wasn’t strong enough when I ran the motherboard without a connected battery. Changing the power supply for a better quality one solved the issue (Both my power supplies were rated 100W, but only one of them made both side thunderbolt ports work).

Of course, this only applies if you run the laptop without a connected battery. If that’s the case I would recommend trying another power supply rated 100+W or with the battery connected.

Hope this helps

thank you for your good answer. I Do not think it is a problem in this case.
I think so because it is only a problem with short cables and both sides are notebooks powered by there own power source… so the framework does not have to power the other notebook.

If the problem occurs only with one specific USB cable and it works with another cable, I would say the cable is likely the issue, not the laptop.

The cable you linked above seems to be certified for USB 4 but not directly for Thunderbolt, so it’s not impossible that it doesn’t work as expected.
(USB 4 cables should be compatible with Thunderbolt 3 but they might not work with Thunderbolt 4).
Also the cable you linked above doesn’t seem to be officially certified with thunderbolt (missing thunderbolt logo on the cable) so it’s not impossible that it’s not working as intended.

Here is a cable that seems to be certified for thunderbolt 4 on amazon.de.

I can fully understand your thoughts and that was my first thought too. And if the cable always had the problem, I would immediately sign it with blood. I also have a working cable, but I want to understand it… at a technical level.