[RESPONDED] Touchpad on Qubes OS (AMD 7840u Framwork 13)

I recently installed Qubes OS on my Framework and the OS works quite well, despite some stability problems.

But the real problem is the touchpad. It doesn’t work.

dom0 seems to detect two peripherals under the label “Mouse” and “Touchpad”.

I’ve tried to update dom0 with the latest kernel but nothing works.

I suspect that even the latest Linux kernel is too old.

Does anyone have any ideas?

Thanks for your help.

1 Like

Hi @Dribble0831 ,
Welcome to the forums,
Does Qube OS uses Xorg? or uses Wayland?
What’s your kernel version? also is PS2 mouse emulation in BIOS enabled?

Qubes works with xorg and kernel version is 6.5.8.

I can’t find the PS2 mouse emulation option in BIOS.

I also can’t find anything about this. When I first started it, a USB mouse worked. Now, 2nd time booting, and the USB mouse doesn’t work. A firewall qube failed to start up during boot, and boot takes forever, like 10 minutes. How did you install it, and are you still using qubes?

Not a distro we test against or provide official support for, however, we do have an active community that has a thread worth going over here (It’s for Intel however, so it will differ):

Additionally, make sure you are on the 3.03 BIOS and not 3.02.

This is not something included in the BIOS. On a supported/tested distro release using our guides to set everything up, the touchpad just works.

How are you getting on with this?

I’ve read on the Qubes forum that bugs have been reported, am also really keen to know whats up.

This issue is also reported in the qubes forums.
I think it’s better to track it with them than Framework as Qubes isn’t in framework’s supported operating system list.

I found the fix : add ioapic_ack=new to the xen boot command line.

In dom0 /etc/default/grub
add ioapic_ack=new to the GRUB_CMDLINE_XEN_DEFAULT

Then grub2-mkconfig -o /boot/grub2/grub.cfg



I followed the issue on github.

Thank you very much for your work :slight_smile:

1 Like