[SOLVED] Ubuntu 23.04 doesn't recognize touchpad properly

For some reason, Ubuntu 23.04 recognized the touchpad as a PS/2 mouse on my gen 11 Framework 13. While this technically works, it also means that the touchpad is not disabled while typing, leading to a lot of annoyance on my end as I seem incapable of not touching it while typing, resulting in frequent mouse “jumps.”

I solved this issue by blacklisting the psmouse module:

echo "blacklist psmouse" | sudo tee -a /etc/modprobe.d/blacklist.conf

After rebooting, the touchpad is recognized as a touchpad and gets disabled while typing is in progress.

I haven’t come across any posts discussing this particular issue, so it might be unique to me. However, I believe it’s worth sharing my experience in case somebody else has this issue. :slight_smile:


Hi @Josip_Medved ,

Thanks posting this up, might be very useful when someone encounters the same issue.


1 Like

Delighted to hear you have found a workaround - curious, how are you connecting a PS/2 port mouse to the Framework 13 - USB adapter I assume?

No, actually Framework’s touchpad gets recognized as PS/2 port mouse by default on my Ubuntu installation. My guess this is due to “PS2 Mouse Emulation” setting in BIOS being enabled (default, I believe).

Another approach would be to disable this in BIOS, but then Windows Setup doesn’t recognize mouse at all which makes it slightly inconvenient.

Interesting, I don’t recall noticing this specifically on a default 22.04 install. Something I will need to look into, thanks for the heads up.