[RESOLVED] Brightness function keys not working on 12th gen Intel system running Pop_OS!

I just installed Pop_OS! 22.04 onto Framework’s 1TB expansion card, and have been booting off of it for the past couple of days. It’s been working great so far—I’ve got my desktop set up the way I like it, and I even got the fingerprint reader working no problem. However, I just cannot seem to get the brightness keys to work. I have tried turning FN lock on and off, but that didn’t make a difference. I can use all of the other important FN keys like volume, play/pause, etc. (airplane mode isn’t working, but I don’t really care about that).

I also tried running the sudo kernelstub -a blacklist_module=hid_sensor_hub command from a terminal, which I found on this Reddit thread, but that unfortunately didn’t fix it for me, even after a reboot. I even tried disabling the ambient light sensor in dconf Editor (/org/gnome/settings-daemon/plugins/power/ambient-enabled), but still nothing.

This thread in the same Reddit post seems to indicate that the issue is related specifically to 12th gen Intel, which I am running (i5-1240P).

I should also point out that I am able to adjust the brightness no problem using the menu in the upper right corner of the screen. It’s just the function keys that don’t work.

TL;DR — Has anyone figured out how to get the FN brightness keys working on 12th gen Intel running Pop OS 22.04?

We don’t test against Pop at this point and recommend Ubuntu 22.04.3, however, two things strike me:

  • If this is a multi-boot computer, making grub or systemd-boot changes may not work as expected.

  • You can try sudo modprobe hid_sensor_hub and see what the results are. Should come back with operation not permitted. If it comes back empty, the blacklisting did not work.

No matter the outcome, I’d try this for Pop - not how we do it elsewhere. Use whichever editor you like.

sudo gedit /etc/modprobe.d/framework-als-blacklist.conf

blacklist hid_sensor_hub

Save, close text editor, run: sudo update-initramfs -u


EDIT: Removed *typo.

Yes, I have Windows installed onto the main SSD, and Pop_OS! on the Framework Expansion Card. I didn’t wanna just jump in head first to switching to Linux, but it looks more and more like I’m gonna be making the switch. If I need Windows, I’ll just run it in a VM.

Running that command DID come back empty, so I guess the blacklist didn’t work.

This also unfortunately didn’t work. When I eventually do move over to installing Pop onto the SSD (in a non-dual boot environment), I’ll try these steps again. Thanks!

Is the “*” at the end a typo and does it impact functionality of the process that parses the files?

@Spence I removed the “*” from the filename, reran sudo update-initramfs -u and rebooted, and that fixed the issue! Such a simple thing that I didn’t think to check, thanks for the suggestion!

1 Like

If the issue comes back after a cold boot (full power off, then power on) check this:

This command will fix it temporarily:

echo i2c-FRMW0001:00 | sudo tee /sys/bus/i2c/drivers/i2c_hid_acpi/bind

1 Like

Yep, this would do it.

@Username009 Luckily since fixing the file name, I haven’t had any further issues with the brightness keys, even after many reboots. Thanks for the info though, good to know!

1 Like