[RESPONDED] Webcam is too dark in Fedora 39

Hi all,

I just received my AMD 13" laptop from Framework yesterday. I’m dual booting Win 11 and Fedora 39. Other than run system updates, I haven’t made many changes to Fedora yet. The camera is super dark. So dark that you can only see the faintest outlines if pointed to a light source, but otherwise the video output of the camera looks black.

In Windows it looks fine. Also, when I reboot the laptop, the very first time I launch a camera related app (just been trying cheese and zoom) the image looks normal for about 1 second before going dark. I’ve tried adjusting brightness/gamma sliders in zoom but that just makes the too dark picture washed out.

Anyone have experience or know a solution to this problem?

I’m on the latest .03 BIOS update for the AMD systems.

I use OBS and you can monkey around with various camera settings using v4l2tools (dnf install qv4l2) - i’ve been relatively impressed with it compared to previous laptop cameras tbh. But it’s still nothing compared to a 4k capture source attached to real glass on a compact digital etc.

Thanks. I’d actually stumbled upon that before posting, but doesn’t seem to help. I’m impatient and actually replacing Fedora w Ubuntu (and recommended kernel) now. I’m more familiar w Ubuntu anyway. We’ll see how things go.

I’ve found qv4l2 is hit and miss, especially in a gtk heavy space.

On Fedora 39:

sudo dnf install guvcview -y

On Ubuntu 22.04.3 (OEM C kernel, all updates run including your snap refresh)

sudo apt update && sudo install apt install guvcview -y

From your Activities, launch guvcview.

In a well lit room, you want to be set about here for the Image tab.

Match this. If you did, are in a well lit room (important) and you’re still seeing this, please screen shot your guvcview settings for me and show me an image from the camera as there may be a hardware issue.

If you need to rest guvcview to defaults, Settings, Hardware Defaults.

Thanks for the info @Matt_Hartley .

In Ubuntu, same issue. I am in a super bright office as I take this:

This is in Ubuntu 22.04.3 LTS. I ran the terminal commands as instructed here for AMD
It’s on kernel 6.2.0-36-generic

That dim diagonal light is overhead fluorescent in a super bright room.

Try toggling the physical camera switch on top of your display on / off and see if that helps. This may be a dual boot issue. There are some nuances switching back and forth without a full shutdown.

1 Like

Hey. The toggle switches didn’t work, but powering off fully and then booting straight into Ubuntu, instead of a reboot from Windows, seems to have worked! Thanks!

So while this should not matter so much from the UVC (webcam) perspective per se, we want other 22.04.3 users on OEM C not default for the kernel.

Posting this for readers looking at this, not for you as you’re merely testing.

This feels like a camera issue and I’d like to get you into a ticket.