Scratching noise under load on gpu


maybe someone can help me or maybe someone can reproduce the noise?
I have a scratching noise when I open e.g. Roll20 or FoundryVTT and the GPU.

Foundry test user

Since I have my own foundry instance, I have provided an account for testing, simply select the user Test. Only one person can use the user at a time.

I have already written to support about this, as it doesn’t seem normal to me, I just wanted to know if I am an isolated case.

Soundfile: Rollenspiel Cloud
If you play the file on the web it is probably too quiet, but with VLC at 125% I could hear the noise.

inxi -Fzx
  Kernel: 6.8.9-300.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.41-34.fc40
  Desktop: GNOME v: 46.1 Distro: Fedora Linux 40.20240511.0 (Silverblue)
  Type: Laptop System: Framework product: Laptop 16 (AMD Ryzen 7040 Series)
    v: AG serial: <superuser required>
  Mobo: Framework model: FRANMZCP07 v: A7 serial: <superuser required>
    UEFI: INSYDE v: 03.03 date: 03/27/2024
  ID-1: BAT1 charge: 88.4 Wh (100.0%) condition: 88.4/85.1 Wh (103.9%)
    volts: 17.5 min: 15.5 model: NVT FRANDBA status: not charging
  Device-1: hid-18:7e:b9:67:f4:86-battery model: Tealk-Magic Trackpad 2
    charge: N/A status: discharging
  Info: 8-core model: AMD Ryzen 7 7840HS w/ Radeon 780M Graphics bits: 64
    type: MT MCP arch: Zen 4 rev: 1 cache: L1: 512 KiB L2: 8 MiB L3: 16 MiB
  Speed (MHz): avg: 1055 high: 4984
    min/max: 400/5137:5293:5449:6080:5764:5924:5608 cores: 1: 400 2: 400 3: 400
    4: 1296 5: 400 6: 400 7: 3507 8: 1350 9: 4984 10: 400 11: 400 12: 400
    13: 400 14: 400 15: 400 16: 1355 bogomips: 121360
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Navi 33 [Radeon RX 7700S/7600/7600S/7600M XT/PRO W7600]
    vendor: Framework driver: amdgpu v: kernel arch: RDNA-3 bus-ID: 03:00.0
  Device-2: AMD Phoenix1 vendor: Framework driver: amdgpu v: kernel
    arch: RDNA-3 bus-ID: c4:00.0 temp: 46.0 C
  Device-3: Logitech C920 PRO HD Webcam driver: snd-usb-audio,uvcvideo
    type: USB bus-ID: 5-
  Display: wayland server: X.Org v: 23.2.6 with: Xwayland v: 23.2.6
    compositor: gnome-shell driver: dri: radeonsi gpu: amdgpu resolution:
    1: 3440x1440~100Hz 2: 2048x1280~165Hz
  API: OpenGL v: 4.6 vendor: amd mesa v: 24.0.6 glx-v: 1.4
    direct-render: yes renderer: AMD Radeon Graphics (radeonsi gfx1103_r1 LLVM
    18.1.1 DRM 3.57 6.8.9-300.fc40.x86_64)
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: AMD Navi 31 HDMI/DP Audio vendor: Framework driver: snd_hda_intel
    v: kernel bus-ID: 03:00.1
  Device-2: AMD Rembrandt Radeon High Definition Audio vendor: Framework
    driver: snd_hda_intel v: kernel bus-ID: c4:00.1
  Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Framework
    driver: snd_pci_ps v: kernel bus-ID: c4:00.5
  Device-4: AMD Family 17h/19h HD Audio vendor: Framework
    driver: snd_hda_intel v: kernel bus-ID: c4:00.6
  Device-5: Logitech C920 PRO HD Webcam driver: snd-usb-audio,uvcvideo
    type: USB bus-ID: 5-
  Device-6: Beyerdynamic FOX driver: hid-generic,snd-usb-audio,usbhid
    type: USB bus-ID: 5-
  API: ALSA v: k6.8.9-300.fc40.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.6 status: active
  Device-1: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    driver: mt7921e v: kernel bus-ID: 04:00.0
  IF: wlp4s0 state: up mac: <filter>
  Device-1: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB
    bus-ID: 1-5:7
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
    lmp-v: 11
  Local Storage: total: 1.82 TiB used: 165.26 GiB (8.9%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WD BLACK SN770 1TB
    size: 931.51 GiB temp: 40.9 C
  ID-2: /dev/sda vendor: Seagate model: UltraTouch SSD size: 931.51 GiB
    type: USB
  ID-1: /boot size: 973.4 MiB used: 293.7 MiB (30.2%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 598.8 MiB used: 12.4 MiB (2.1%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /var size: 929.91 GiB used: 117.53 GiB (12.6%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-91874fa2-dc37-4bd0-aee8-c4a03dee90d0
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 51.2 C mobo: N/A
  Fan Speeds (rpm): N/A
  GPU: device: amdgpu temp: N/A device: amdgpu temp: 40.0 C fan: 0
  Memory: total: 32 GiB note: est. available: 30.65 GiB used: 7.82 GiB (25.5%)
  Processes: 497 Uptime: 57m Init: systemd target: graphical (5)
  Packages: 77 Compilers: N/A Shell: Bash v: 5.2.26 inxi: 3.3.34

I’ve downloaded the file and amplified the volume, as it was barely recognizable on my FW16 even with volume all the way up, plus you named an AAC/MP4Audio a MP3, but it’s ok, that’s what filter and plugins are for :smiley:
Upload files for free - scratching noise.mp3 - (auto-deletes after 30 days)

As to the problem, I’m not sure, if the noise is mechanical or electric. To me, it sounds like something is very close to a fans blades on the intake side. Where exactly did you record the sound, can you say if it’s louder left, middle or right, front or back?

It could also be coil whine, though the frequency seems to be too low for that.
The Cyberpunk Browsergame puts some load on the GPU, but not very heavy load, the iGPU is at 75%, CPU stays below 10%. I tried different settings, 60Hz on the monitor, vsync on/off, Radeon chill, FPS Target, it stays the same.

Try Furmark and play with the settings so you can achieve different FPS and listen if it also occurs, either all the time, goes up with fans spinning up or changes with FPS.

1 Like

sorry for the silent file, i had no contact with audio formats so far, i had to think about how to record it xD

It sounds a bit like an old HDD I must say and I don’t think it has anything to do with the fan, because regardless of the speed of the fans the noise remains the same/similar.

I would say the noise comes from the GPU, at least that’s where you can hear it best.

This is what my load looks like when I have cyberpunkt open, I can hear this constant scratching noise. As soon as I close the browser, it disappears immediately.

When I use FurMark, I don’t have this noise, regardless of the settings when i use the gpu of the processor, as soon as i use the 7700S i have the following behaviour:

If I switch off the “Render furry object” option, I have a noise like a horn

Oh with VSync active I get a louder version of scratching

Then it seems like an electrical noise, or coil whine.
Every part with R15 written on or R33 is a coil, when the GPU die needs power, the current flow isn’t consistent, but always changing, with fast changing peaks and plateaus, this is when coils can make a noise. It seems, you got a dGPU with coil whine.

Normally, this would not be a warranty issue, because it’s not a defect but a side effect of how coils are working. Usually they are embedded in resin like substance inside the case to prevent vibrations, but sometimes this is not enough or badly done. But you could ask FW support for a replacement. But be aware, that the new one might make the same or even more annoying, different noises.

From the look at the heatsink part in the market place, the coils already seem to be prepared with a thermal pad. Thing is: Cooler coils whine more. On many desktop cards they are not connected to the cooler via pads or paste because of that. On the other hand, the thermal pad should fixate the lid, so I’m not sure, how they are making any noise.

If you don’t care about warranty, there is also another way to suppress the noise, like gap filling instant glue, which you can put between the body and the lid of the coils casing. I’ve done the same with either a Radeon Fury or Vega 64 I had earlier, I’m not sure right now. It works.
In this video he does not do it, but tells about it and it sounds similar to your problem:

But that can’t be the point of a new device making noise that disrupts daily operation.

It’s not like it’s an inconspicuous noise, you can hear it loudly and it’s also disruptive during any voice meetings.

This is also the first time I’ve had this and I’ve had a lot of hardware and I work in IT and none of the 200 or so devices there that I look after have ever made a noise that wasn’t the fan or coming from the speaker

But what I also don’t understand is why does the “Render furry object” prevent it from making noise?


i can’t find a download on the site, or what are you trying to tell me?

You need to download the drivers for the amd 7700 s. Search Google to download amd 7700 s drivers.

This could solve the problem

amdgpu should already be the driver, right?

03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Navi 33 [Radeon RX 7700S/7600/7600S/7600M XT/PRO W7600] (rev c1) (prog-if 00 [VGA controller])
	DeviceName: Realtek
	Subsystem: Framework Computer Inc. Device 0007
	Flags: bus master, fast devsel, latency 0, IRQ 79, IOMMU group 15
	Memory at 7c00000000 (64-bit, prefetchable) [size=8G]
	Memory at 7e00000000 (64-bit, prefetchable) [size=256M]
	I/O ports at a000 [size=256]
	Memory at 90c00000 (32-bit, non-prefetchable) [size=1M]
	Expansion ROM at 90d20000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu

Apart from that, I can’t find any instructions on how to install the driver for Fedora silverblue.

Different FPS means different current flow. Sometimes this means, there are more plateaus and less peaks or vice versa, so that the resonance frequency is not met.

I have a noise problem too, I spoke to another user who solved it this way. Unfortunately in my case it didn’t work.

i’m currently waiting for a reply from support, i don’t want to lose the warranty because i’m tinkering with the device too quickly. It is very annoying for me and it would be great if I could get rid of it.

Hello, I am also talking to them. They are a good sat but they are very slow. Although it is true that they comply with the warranty.

I got the confirmation today that my GPU will be replaced

1 Like

I have a scratching noise problem too. Yesterday I wrote to support, and today they confirmed the replacement of the dGPU to me.

1 Like

I got my replacement graphics card today, unfortunately it makes just as much, if not more noise than the old one :cry:

:thinking: :dizzy_face: how is that possible?

Read up on coil whine etc.

Search here and ‘there’ for lots of ‘scratching’ noises :slight_smile:

Did you see the post above, with a fix? have you tested and tried that ?

I dont know :frowning:

I’ve read about it, but I haven’t dared to try it yet, lest I invalidate the warranty

1 Like

You don’t have to fix it. Can you access the and try and see if that is the problem or does the access void the warantee.

I only have the 13" so can’t check.