Screen Framework 13 AMD stays black

Hello everyone,

I bought a DIY Framework 13 AMD and put it together according to the guide. When I tried to turn it on, the screen just stayed black. The power button is on and the fans as well.
I tried starting everything from the beginning, disconnected everything and put it back together, disconnected the screen and put it back on, let it charge a whole day before trying it again…nothing…
Does anyone have an idea what the problem is ?

Welcome to the community! :slight_smile:

You may have to give it a little extra time on the first boot. I don’t know what’s normal for that, it might depend on things like how much memory you have, but if the screen remains black after ten or fifteen minutes, then something is definitely wrong.

Unfortunately, figuring out exactly what is wrong would be pretty difficult from here. I’d suggest contacting Framework support about it. They should have troubleshooting steps to identify exactly what’s wrong and how to fix it. I think they’re pretty swamped right now due to the Framework 16 launch, so it might be a slow process.

1 Like

make sure the RAM is fitted in correctly. One trick is also to remove the SSD and one ram module and leave only one RAM module and power it on again.
DDR5 system, if the RAM is not really good, it tries to test it and learn the bad memory block locations to avoid these. This can take up to an hour or so if the ram is really bad.

1 Like

Thanks, I wasn’t aware of that.

1 Like