[TRACKING] No display at all on very first boot


I just received the Framework 13 AMD DIY and followed the instructions. Harddrive and memory are those provided by Framework.

On first boot, the power lights up (in white) but the screen stays black, even after 10 minutes, only the fans starts!

The only weird thing I noticed is that the Touchpad Cable is plugged in slightly tilted, but It seems I cannot plug in it better than that.

Could it be the cause of the encoutered problem?

step 8 on the guide : Framework Laptop 13 (AMD Ryzen™ 7040 Series) DIY Edition Quick Start Guide - Framework Guides

Anybody can help for the debug?

Welcome to the community!

I’d definitely open a support ticket for this one.

I doubt the tilted touchpad cable is the problem if power button turned it on. That means it’s working.

I got my AMD 13 laptop today as well and have the same issue. The laptop seems to be booting fine (passes diagnostic and post) but the screen is completely black.

There may be a common issue here needing further investigation.

My Framework 13 AMD is running into the same problem. The power light goes on, the screen stays black, and after a few minutes the machine gets super hot and the fans kick on.

Edit: I re-seated the RAM/SSD and put the laptop back together and it works properly :slight_smile:

1 Like

Welcome to the community, delighted to hear the re-seating the ram helped.

I also re-seated the RAM/SSD but nothing changed.

I just noticed a light sequence on the LED of the USB port :

Green (13 Times)
Green (3 Times)

I don’t known if it can help to diagnose the problem…

@xian - that looks like that is 0x15. From here that is PCI Enumeration Complete: Framework Laptop port80 codes · GitHub

Likely best to open a ticket with Support.

Same issue here, I believe. I assembled the laptop, plugged it in, press power, and nothing happens other than the power light turning on. The LED on the charging module stays solid orange, and eventually the fans turn on, but otherwise nothing.

Edit: reseating the ram did not help. The only change so far is that the LED is now white after fully charging.

2nd edit: I am now getting a post code so I opened a support ticket.

3rd edit: The issue with my machine is that DIMM channel 0 is not functional, only channel 1.

Finally I have the same error than Freemcclure:

I plugged the RAM on the other slot and… it worked!

The issue with my machine is that DIMM channel 0 is not functional, only channel 1.

Welcome to the community!

I’d definitely open a support ticket for this one.

I’ve also got this issue with my new Framework 13 AMD 7040.
Already opened a support ticket.
Did not try to switch the RAM module to channel 1 for now but I removed, put it back in place and checked if it sits properly in channel 0.
Did not change anything.
I also noticed the device getting hot and the fan spinning at different speeds.

I received my Framework 13 AMD 7640U today and I have the same issue.
I tried reseating the ram on both slots several times and it’s always the same :
The laptop won’t start with the RAM seated in slot 0, only on slot 1

I also opened a support ticket for that.

Looks like this is a common issue, I reported same issue(ram slot not working) with support team, and they said they are going to send me a new mainboard(maybe after the holiday). Still have few questions but they hardly reply the emails.

is there anyone solved issue after replacing the mainboard?
and anyone knows the reason? was it glue? or just low voltage?

I had the same issue and reported it on the 18th (right opening the laptop at my parents house).
I have also seen other users have this issue on reddit.

I wrote that I am looking to fix the laptop and want to return it if there is no fix.
I have recieved a mail with a return label and a message that the repair team is very occupied at the moment.
Not yet any news on if I will get a replacement mainboard or if there is any fix.

I really hope that I will soon get a mail because I need to use a new laptop for university and I already delayed getting one because I really wanted the framework :slight_smile: .
Exited to use a working one soon :crossed_fingers: